CVE-2026-118257
CVE-2026-118257 · Vue I18n: escapeParameter does not prevent XSS through srcdoc in translation messages
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Esta página muestra una selección de datos de las fuentes. Consulte los avisos enlazados para ver la descripción completa y las versiones afectadas.
Vue I18n is the internationalization plugin for Vue.js. From 11.1.10 until 11.4.14 and from 12.0.0-alpha.4 until 12.0.0-alpha.5, sanitizeTranslatedHtml() escapes markup and event-handler text inside an iframe srcdoc value but leaves the srcdoc attribute active. Browsers decode the character references and parse the value as a same-origin nested HTML document, allowing attacker-controlled parameters or translation content placed in srcdoc to execute script when applications enable escapeParameter and render translations as HTML through v-html. Versions 9.14.5 and 10.0.8 are also affected and are no longer supported, while i18n-t rendering is not affected. This issue is fixed in versions 11.4.14 and 12.0.0-alpha.5.
CVSS 7.2 · Alta · EPSS 0,3% · Código de explotación público · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: node
Productos y versiones afectados
vue-i18n
- Versiones
- = 9.14.5: Afectada
- = 10.0.8: Afectada
- >= 11.1.10, < 11.4.14: Afectada
- >= 12.0.0-alpha.4, < 12.0.0-alpha.5: Afectada
Sin corrección publicada
vue-i18n npm
- Versiones
- 9.14.5
Sin corrección publicada
vue-i18n npm
- Versiones
- 10.0.8
Sin corrección publicada
vue-i18n npm
- Intervalos de versiones afectados
- SEMVER: ≥ 11.1.10, < 11.4.14
Actualiza a 11.4.14
vue-i18n npm
- Versiones
- 12.0.0-alpha.4
- Intervalos de versiones afectados
- SEMVER: ≥ 12.0.0-alpha.4, < 12.0.0-alpha.5
Actualiza a 12.0.0-alpha.5
petite-vue-i18n npm
- Versiones
- 9.14.5
Sin corrección publicada
petite-vue-i18n npm
- Versiones
- 10.0.8
Sin corrección publicada
petite-vue-i18n npm
- Intervalos de versiones afectados
- SEMVER: ≥ 11.1.10, < 11.4.14
Actualiza a 11.4.14
petite-vue-i18n npm
- Versiones
- 12.0.0-alpha.4
- Intervalos de versiones afectados
- SEMVER: ≥ 12.0.0-alpha.4, < 12.0.0-alpha.5
Actualiza a 12.0.0-alpha.5
@intlify/core-base npm
- Versiones
- 9.14.5
Sin corrección publicada
@intlify/core-base npm
- Versiones
- 10.0.8
Sin corrección publicada
@intlify/core-base npm
- Intervalos de versiones afectados
- SEMVER: ≥ 11.1.10, < 11.4.14
Actualiza a 11.4.14
@intlify/core-base npm
- Versiones
- 12.0.0-alpha.4
- Intervalos de versiones afectados
- SEMVER: ≥ 12.0.0-alpha.4, < 12.0.0-alpha.5
Actualiza a 12.0.0-alpha.5
@intlify/core npm
- Versiones
- 9.14.5
Sin corrección publicada
@intlify/core npm
- Versiones
- 10.0.8
Sin corrección publicada
@intlify/core npm
- Intervalos de versiones afectados
- SEMVER: ≥ 11.1.10, < 11.4.14
Actualiza a 11.4.14
@intlify/core npm
- Versiones
- 12.0.0-alpha.4
- Intervalos de versiones afectados
- SEMVER: ≥ 12.0.0-alpha.4, < 12.0.0-alpha.5
Actualiza a 12.0.0-alpha.5
@intlify/vue-i18n-core npm
- Versiones
- 9.14.5
Sin corrección publicada
@intlify/vue-i18n-core npm
- Versiones
- 10.0.8
Sin corrección publicada
@intlify/vue-i18n-core npm
- Intervalos de versiones afectados
- SEMVER: ≥ 11.1.10, < 11.4.14
Actualiza a 11.4.14
@intlify/vue-i18n-core npm
- Versiones
- 12.0.0-alpha.4
- Intervalos de versiones afectados
- SEMVER: ≥ 12.0.0-alpha.4, < 12.0.0-alpha.5
Actualiza a 12.0.0-alpha.5
@intlify/shared npm
- Versiones
- 9.14.5
Sin corrección publicada
@intlify/shared npm
- Versiones
- 10.0.8
Sin corrección publicada
@intlify/shared npm
- Intervalos de versiones afectados
- SEMVER: ≥ 11.1.10, < 11.4.14
Actualiza a 11.4.14
Fuentes originales
- https://github.com/intlify/vue-i18n/security/advisories/GHSA-83rm-6c8r-g728
- https://github.com/intlify/vue-i18n/pull/2679
- https://github.com/intlify/vue-i18n/commit/43391d20e7c85403cb59bdb21b5d542819f54042
- https://github.com/intlify/vue-i18n/releases/tag/v11.4.14
- https://github.com/intlify/vue-i18n/releases/tag/v12.0.0-alpha.5
- https://nvd.nist.gov/vuln/detail/CVE-2026-118257