p PatchFirst

CVE-2026-118257

CVE-2026-118257 · Vue I18n: escapeParameter does not prevent XSS through srcdoc in translation messages

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Diese Seite zeigt ausgewählte Angaben aus den Quellen. Die vollständige Beschreibung und betroffene Versionen finden Sie in den verlinkten Sicherheitshinweisen.

Vue I18n is the internationalization plugin for Vue.js. From 11.1.10 until 11.4.14 and from 12.0.0-alpha.4 until 12.0.0-alpha.5, sanitizeTranslatedHtml() escapes markup and event-handler text inside an iframe srcdoc value but leaves the srcdoc attribute active. Browsers decode the character references and parse the value as a same-origin nested HTML document, allowing attacker-controlled parameters or translation content placed in srcdoc to execute script when applications enable escapeParameter and render translations as HTML through v-html. Versions 9.14.5 and 10.0.8 are also affected and are no longer supported, while i18n-t rendering is not affected. This issue is fixed in versions 11.4.14 and 12.0.0-alpha.5.

CVSS 7.2 · Hoch · EPSS 0,3% · Öffentlicher Exploit · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: node

Betroffene Produkte und Versionen

  • vue-i18n

    Softwareversionen
    • = 9.14.5: Betroffen
    • = 10.0.8: Betroffen
    • >= 11.1.10, < 11.4.14: Betroffen
    • >= 12.0.0-alpha.4, < 12.0.0-alpha.5: Betroffen

    Keine Korrektur veröffentlicht

  • vue-i18n npm

    Softwareversionen
    • 9.14.5

    Keine Korrektur veröffentlicht

  • vue-i18n npm

    Softwareversionen
    • 10.0.8

    Keine Korrektur veröffentlicht

  • vue-i18n npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 11.1.10, < 11.4.14

    Auf 11.4.14 aktualisieren

  • vue-i18n npm

    Softwareversionen
    • 12.0.0-alpha.4
    Betroffene Versionsbereiche
    • SEMVER: ≥ 12.0.0-alpha.4, < 12.0.0-alpha.5

    Auf 12.0.0-alpha.5 aktualisieren

  • petite-vue-i18n npm

    Softwareversionen
    • 9.14.5

    Keine Korrektur veröffentlicht

  • petite-vue-i18n npm

    Softwareversionen
    • 10.0.8

    Keine Korrektur veröffentlicht

  • petite-vue-i18n npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 11.1.10, < 11.4.14

    Auf 11.4.14 aktualisieren

  • petite-vue-i18n npm

    Softwareversionen
    • 12.0.0-alpha.4
    Betroffene Versionsbereiche
    • SEMVER: ≥ 12.0.0-alpha.4, < 12.0.0-alpha.5

    Auf 12.0.0-alpha.5 aktualisieren

  • @intlify/core-base npm

    Softwareversionen
    • 9.14.5

    Keine Korrektur veröffentlicht

  • @intlify/core-base npm

    Softwareversionen
    • 10.0.8

    Keine Korrektur veröffentlicht

  • @intlify/core-base npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 11.1.10, < 11.4.14

    Auf 11.4.14 aktualisieren

  • @intlify/core-base npm

    Softwareversionen
    • 12.0.0-alpha.4
    Betroffene Versionsbereiche
    • SEMVER: ≥ 12.0.0-alpha.4, < 12.0.0-alpha.5

    Auf 12.0.0-alpha.5 aktualisieren

  • @intlify/core npm

    Softwareversionen
    • 9.14.5

    Keine Korrektur veröffentlicht

  • @intlify/core npm

    Softwareversionen
    • 10.0.8

    Keine Korrektur veröffentlicht

  • @intlify/core npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 11.1.10, < 11.4.14

    Auf 11.4.14 aktualisieren

  • @intlify/core npm

    Softwareversionen
    • 12.0.0-alpha.4
    Betroffene Versionsbereiche
    • SEMVER: ≥ 12.0.0-alpha.4, < 12.0.0-alpha.5

    Auf 12.0.0-alpha.5 aktualisieren

  • @intlify/vue-i18n-core npm

    Softwareversionen
    • 9.14.5

    Keine Korrektur veröffentlicht

  • @intlify/vue-i18n-core npm

    Softwareversionen
    • 10.0.8

    Keine Korrektur veröffentlicht

  • @intlify/vue-i18n-core npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 11.1.10, < 11.4.14

    Auf 11.4.14 aktualisieren

  • @intlify/vue-i18n-core npm

    Softwareversionen
    • 12.0.0-alpha.4
    Betroffene Versionsbereiche
    • SEMVER: ≥ 12.0.0-alpha.4, < 12.0.0-alpha.5

    Auf 12.0.0-alpha.5 aktualisieren

  • @intlify/shared npm

    Softwareversionen
    • 9.14.5

    Keine Korrektur veröffentlicht

  • @intlify/shared npm

    Softwareversionen
    • 10.0.8

    Keine Korrektur veröffentlicht

  • @intlify/shared npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 11.1.10, < 11.4.14

    Auf 11.4.14 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →