p PatchFirst

CVE-2026-12590

CVE-2026-12590 · body-parser vulnerable to denial of service when invalid limit value silently disables size enforcement

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Impact: In body-parser versions prior to 1.20.6 (1.x line) and 2.3.0 (2.x line), when the parser is configured with an invalid limit option value such as an unparseable string or NaN, bytes.parse returns null and the request body size check is silently skipped. Applications that rely on limit as their primary safeguard against oversized request bodies will accept arbitrarily large payloads, leading to excessive memory and CPU usage and denial of service. Patches: This issue is fixed in body-parser 1.20.6 and 2.3.0. After the fix, invalid limit values throw a clear error at parser construction time instead of silently disabling enforcement, while null and undefined continue to fall back to the default limit of 100kb. Workarounds: Validate the limit value before passing it to body-parser. For example, parse the value at startup and reject any configuration where the result is null or a non-finite number.

CVSS 3.7 · Baja · EPSS 0,4% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system · node

Productos y versiones afectados

  • body-parser

    Versiones
    • ≥ 0, < 1.20.6: Afectada (semver)
    • 1.20.6: No afectada (semver)
    • ≥ 2.0.0, < 2.3.0: Afectada (semver)
    • 2.3.0: No afectada (semver)

    Actualiza a 1.20.6; Actualiza a 2.3.0

  • node-body-parser Debian:12

    Versiones
    • 1.20.1+~1.19.2-1
    • 1.20.2+~1.19.5-1
    • 1.20.3+~1.19.5-1
    • 1.20.3+~1.19.5-2
    • 1.20.3+~1.19.5-3
    • 2.2.0+~1.19.6-1
    • 2.2.0+~1.19.6-2
    • 2.2.0+~1.19.6-3
    • 2.2.1+~1.19.6-1
    • 2.2.2+~1.19.6-1
    • 2.3.0+~1.19.6-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-body-parser Debian:13

    Versiones
    • 1.20.3+~1.19.5-3
    • 2.2.0+~1.19.6-1
    • 2.2.0+~1.19.6-2
    • 2.2.0+~1.19.6-3
    • 2.2.1+~1.19.6-1
    • 2.2.2+~1.19.6-1
    • 2.3.0+~1.19.6-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-body-parser Debian:14

    Versiones
    • 1.20.3+~1.19.5-3
    • 2.2.0+~1.19.6-1
    • 2.2.0+~1.19.6-2
    • 2.2.0+~1.19.6-3
    • 2.2.1+~1.19.6-1
    • 2.2.2+~1.19.6-1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.3.0+~1.19.6-1

    Actualiza a 2.3.0+~1.19.6-1

  • body-parser npm

    Intervalos de versiones afectados
    • SEMVER: < 1.20.6

    Actualiza a 1.20.6

  • body-parser npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 2.0.0, < 2.3.0

    Actualiza a 2.3.0

  • node-body-parser Ubuntu:16.04:LTS

    Versiones
    • 1.8.1-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-body-parser Ubuntu:18.04:LTS

    Versiones
    • 1.8.1-1
    • 1.8.1-1ubuntu1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-body-parser Ubuntu:20.04:LTS

    Versiones
    • 1.18.3-2
    • 1.19.0-2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-body-parser Ubuntu:22.04:LTS

    Versiones
    • 1.19.0-2
    • 1.19.0-5
    • 1.19.1+~1.19.2-1
    • 1.19.2+~1.19.2-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-body-parser Ubuntu:24.04:LTS

    Versiones
    • 1.20.1+~1.19.2-1
    • 1.20.2+~1.19.5-1
    • 1.20.2+~1.19.5-1build2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-body-parser Ubuntu:25.10

    Versiones
    • 1.20.3+~1.19.5-3
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-body-parser Ubuntu:26.10

    Versiones
    • 2.2.2+~1.19.6-1
    • 2.3.0+~1.19.6-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-body-parser Ubuntu:26.04:LTS

    Versiones
    • 1.20.3+~1.19.5-3
    • 2.2.0+~1.19.6-1
    • 2.2.2+~1.19.6-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

Fuentes originales

Comprueba tu servidor →