CVE-2026-12590
CVE-2026-12590 · body-parser vulnerable to denial of service when invalid limit value silently disables size enforcement
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Impact: In body-parser versions prior to 1.20.6 (1.x line) and 2.3.0 (2.x line), when the parser is configured with an invalid limit option value such as an unparseable string or NaN, bytes.parse returns null and the request body size check is silently skipped. Applications that rely on limit as their primary safeguard against oversized request bodies will accept arbitrarily large payloads, leading to excessive memory and CPU usage and denial of service. Patches: This issue is fixed in body-parser 1.20.6 and 2.3.0. After the fix, invalid limit values throw a clear error at parser construction time instead of silently disabling enforcement, while null and undefined continue to fall back to the default limit of 100kb. Workarounds: Validate the limit value before passing it to body-parser. For example, parse the value at startup and reject any configuration where the result is null or a non-finite number.
CVSS 3.7 · Niedrig · EPSS 0,4% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · node
Betroffene Produkte und Versionen
body-parser
- Softwareversionen
- ≥ 0, < 1.20.6: Betroffen (semver)
- 1.20.6: Nicht betroffen (semver)
- ≥ 2.0.0, < 2.3.0: Betroffen (semver)
- 2.3.0: Nicht betroffen (semver)
Auf 1.20.6 aktualisieren; Auf 2.3.0 aktualisieren
node-body-parser Debian:12
- Softwareversionen
- 1.20.1+~1.19.2-1
- 1.20.2+~1.19.5-1
- 1.20.3+~1.19.5-1
- 1.20.3+~1.19.5-2
- 1.20.3+~1.19.5-3
- 2.2.0+~1.19.6-1
- 2.2.0+~1.19.6-2
- 2.2.0+~1.19.6-3
- 2.2.1+~1.19.6-1
- 2.2.2+~1.19.6-1
- 2.3.0+~1.19.6-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-body-parser Debian:13
- Softwareversionen
- 1.20.3+~1.19.5-3
- 2.2.0+~1.19.6-1
- 2.2.0+~1.19.6-2
- 2.2.0+~1.19.6-3
- 2.2.1+~1.19.6-1
- 2.2.2+~1.19.6-1
- 2.3.0+~1.19.6-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-body-parser Debian:14
- Softwareversionen
- 1.20.3+~1.19.5-3
- 2.2.0+~1.19.6-1
- 2.2.0+~1.19.6-2
- 2.2.0+~1.19.6-3
- 2.2.1+~1.19.6-1
- 2.2.2+~1.19.6-1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.3.0+~1.19.6-1
Auf 2.3.0+~1.19.6-1 aktualisieren
body-parser npm
- Betroffene Versionsbereiche
- SEMVER: < 1.20.6
Auf 1.20.6 aktualisieren
body-parser npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 2.0.0, < 2.3.0
Auf 2.3.0 aktualisieren
node-body-parser Ubuntu:16.04:LTS
- Softwareversionen
- 1.8.1-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-body-parser Ubuntu:18.04:LTS
- Softwareversionen
- 1.8.1-1
- 1.8.1-1ubuntu1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-body-parser Ubuntu:20.04:LTS
- Softwareversionen
- 1.18.3-2
- 1.19.0-2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-body-parser Ubuntu:22.04:LTS
- Softwareversionen
- 1.19.0-2
- 1.19.0-5
- 1.19.1+~1.19.2-1
- 1.19.2+~1.19.2-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-body-parser Ubuntu:24.04:LTS
- Softwareversionen
- 1.20.1+~1.19.2-1
- 1.20.2+~1.19.5-1
- 1.20.2+~1.19.5-1build2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-body-parser Ubuntu:25.10
- Softwareversionen
- 1.20.3+~1.19.5-3
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-body-parser Ubuntu:26.10
- Softwareversionen
- 2.2.2+~1.19.6-1
- 2.3.0+~1.19.6-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-body-parser Ubuntu:26.04:LTS
- Softwareversionen
- 1.20.3+~1.19.5-3
- 2.2.0+~1.19.6-1
- 2.2.2+~1.19.6-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht