p PatchFirst

CVE-2026-14257

CVE-2026-14257 · brace-expansion DoS via unbounded expansion length causing an out-of-memory process crash

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

brace-expansion through 5.0.7 is vulnerable to denial of service via memory exhaustion. The expand() function limits the number of results with a max option (default 100,000) but does not bound the length of each result string. By chaining multiple brace groups, an attacker keeps the result count under the limit while making each result progressively longer, so total memory scales with both count and string length until the process hits a fatal, uncatchable out-of-memory error. About 7.5 KB of input ('{a,b}'.repeat(1500)) crashes a default Node.js process. Any application that passes attacker-influenced strings to brace-expansion.expand() - directly or transitively via minimatch / glob brace patterns - can be crashed by a small request. Fixed in 5.0.8 by adding a maxLength option (default 4,000,000) that bounds accumulated output and intermediate arrays.

CVSS 7.5 · Alta · EPSS 0,6% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system · node

Productos y versiones afectados

  • brace-expansion

    Versiones
    • ≥ 0, ≤ 5.0.7: Afectada (semver)

    Sin corrección publicada

  • node-brace-expansion Debian:12

    Versiones
    • 2.0.1+~1.1.0-1
    • 2.0.1+~1.1.0-2
    • 2.0.1-2
    • 2.0.3+~1.1.2-1
    • 2.0.3+~1.1.2-2
    • 2.0.3+~1.1.2-3
    • 2.1.4+~1.1.2-1
    • 2.1.7+~1.1.2-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-brace-expansion Debian:13

    Versiones
    • 2.0.1+~1.1.0-2
    • 2.0.3+~1.1.2-1
    • 2.0.3+~1.1.2-2
    • 2.0.3+~1.1.2-3
    • 2.1.4+~1.1.2-1
    • 2.1.7+~1.1.2-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-brace-expansion Debian:14

    Versiones
    • 2.0.1+~1.1.0-2
    • 2.0.3+~1.1.2-1
    • 2.0.3+~1.1.2-2
    • 2.0.3+~1.1.2-3
    • 2.1.4+~1.1.2-1
    • 2.1.7+~1.1.2-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • brace-expansion npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 4.0.0, < 5.0.8

    Actualiza a 5.0.8

  • brace-expansion npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 3.0.0, < 3.0.3

    Actualiza a 3.0.3

  • brace-expansion npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 2.0.0, < 2.1.3

    Actualiza a 2.1.3

  • brace-expansion npm

    Intervalos de versiones afectados
    • SEMVER: < 1.1.17

    Actualiza a 1.1.17

  • node-brace-expansion Ubuntu:18.04:LTS

    Versiones
    • 1.1.8-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-brace-expansion Ubuntu:20.04:LTS

    Versiones
    • 1.1.8-1
    • 1.1.11-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-brace-expansion Ubuntu:22.04:LTS

    Versiones
    • 2.0.0-1
    • 2.0.1-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-brace-expansion Ubuntu:24.04:LTS

    Versiones
    • 2.0.1-2
    • 2.0.1+~1.1.0-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-brace-expansion Ubuntu:26.10

    Versiones
    • 2.0.1+~1.1.0-2
    • 2.0.3+~1.1.2-2
    • 2.0.3+~1.1.2-3
    • 2.1.4+~1.1.2-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-brace-expansion Ubuntu:26.04:LTS

    Versiones
    • 2.0.1+~1.1.0-2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

Fuentes originales

Comprueba tu servidor →