p PatchFirst

CVE-2026-14257

CVE-2026-14257 · brace-expansion DoS via unbounded expansion length causing an out-of-memory process crash

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

brace-expansion through 5.0.7 is vulnerable to denial of service via memory exhaustion. The expand() function limits the number of results with a max option (default 100,000) but does not bound the length of each result string. By chaining multiple brace groups, an attacker keeps the result count under the limit while making each result progressively longer, so total memory scales with both count and string length until the process hits a fatal, uncatchable out-of-memory error. About 7.5 KB of input ('{a,b}'.repeat(1500)) crashes a default Node.js process. Any application that passes attacker-influenced strings to brace-expansion.expand() - directly or transitively via minimatch / glob brace patterns - can be crashed by a small request. Fixed in 5.0.8 by adding a maxLength option (default 4,000,000) that bounds accumulated output and intermediate arrays.

CVSS 7.5 · Hoch · EPSS 0,6% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · node

Betroffene Produkte und Versionen

  • brace-expansion

    Softwareversionen
    • ≥ 0, ≤ 5.0.7: Betroffen (semver)

    Keine Korrektur veröffentlicht

  • node-brace-expansion Debian:12

    Softwareversionen
    • 2.0.1+~1.1.0-1
    • 2.0.1+~1.1.0-2
    • 2.0.1-2
    • 2.0.3+~1.1.2-1
    • 2.0.3+~1.1.2-2
    • 2.0.3+~1.1.2-3
    • 2.1.4+~1.1.2-1
    • 2.1.7+~1.1.2-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-brace-expansion Debian:13

    Softwareversionen
    • 2.0.1+~1.1.0-2
    • 2.0.3+~1.1.2-1
    • 2.0.3+~1.1.2-2
    • 2.0.3+~1.1.2-3
    • 2.1.4+~1.1.2-1
    • 2.1.7+~1.1.2-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-brace-expansion Debian:14

    Softwareversionen
    • 2.0.1+~1.1.0-2
    • 2.0.3+~1.1.2-1
    • 2.0.3+~1.1.2-2
    • 2.0.3+~1.1.2-3
    • 2.1.4+~1.1.2-1
    • 2.1.7+~1.1.2-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • brace-expansion npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 4.0.0, < 5.0.8

    Auf 5.0.8 aktualisieren

  • brace-expansion npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 3.0.0, < 3.0.3

    Auf 3.0.3 aktualisieren

  • brace-expansion npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 2.0.0, < 2.1.3

    Auf 2.1.3 aktualisieren

  • brace-expansion npm

    Betroffene Versionsbereiche
    • SEMVER: < 1.1.17

    Auf 1.1.17 aktualisieren

  • node-brace-expansion Ubuntu:18.04:LTS

    Softwareversionen
    • 1.1.8-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-brace-expansion Ubuntu:20.04:LTS

    Softwareversionen
    • 1.1.8-1
    • 1.1.11-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-brace-expansion Ubuntu:22.04:LTS

    Softwareversionen
    • 2.0.0-1
    • 2.0.1-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-brace-expansion Ubuntu:24.04:LTS

    Softwareversionen
    • 2.0.1-2
    • 2.0.1+~1.1.0-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-brace-expansion Ubuntu:26.10

    Softwareversionen
    • 2.0.1+~1.1.0-2
    • 2.0.3+~1.1.2-2
    • 2.0.3+~1.1.2-3
    • 2.1.4+~1.1.2-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-brace-expansion Ubuntu:26.04:LTS

    Softwareversionen
    • 2.0.1+~1.1.0-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →