p PatchFirst

CVE-2026-19113

CVE-2026-19113 · Unauthenticated denial of service via unbounded request body processing

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Consul Community Edition and Consul Enterprise 1.3.0 through 2.0.2 are vulnerable to an unauthenticated denial of service in several agent HTTP API endpoints. A remote caller could cause the agent to consume substantial memory before the request was rejected. This vulnerability, CVE-2026-19113, is fixed in Consul 2.0.3 and Consul Enterprise 1.21.17, 1.22.11, and 2.0.3.

CVSS 5.3 · Media · EPSS 0,4% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system

Productos y versiones afectados

  • consul

    Versiones
    • ≥ 1.3.0, < 2.0.3: Afectada (semver)

    Actualiza a 2.0.3

  • consul enterprise

    Versiones
    • ≥ 1.3.0, < 2.0.3: Afectada; ≥ 1.21.17: No afectada; ≥ 1.22.11: No afectada (semver)

    Actualiza a 1.21.17

  • consul Debian:11

    Versiones
    • 1.10.12+dfsg1-1
    • 1.8.7+dfsg1-2
    • 1.8.7+dfsg1-3
    • 1.8.7+dfsg1-4
    • 1.8.7+dfsg1-5
    • 1.8.7+dfsg1-6
    • 1.9.17+dfsg2-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • consul Ubuntu:18.04:LTS

    Versiones
    • 0.6.4~dfsg-3
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • consul Ubuntu:20.04:LTS

    Versiones
    • 1.0.7~dfsg1-5ubuntu1
    • 1.4.4~dfsg1-2ubuntu2
    • 1.5.2+dfsg1-6
    • 1.5.2+dfsg1-10
    • 1.5.2+dfsg1-12
    • 1.5.2+dfsg2-14
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • consul Ubuntu:22.04:LTS

    Versiones
    • 1.7.4+dfsg1-1
    • 1.8.7+dfsg1-3
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

Fuentes originales

Comprueba tu servidor →