p PatchFirst

CVE-2026-19113

CVE-2026-19113 · Unauthenticated denial of service via unbounded request body processing

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Consul Community Edition and Consul Enterprise 1.3.0 through 2.0.2 are vulnerable to an unauthenticated denial of service in several agent HTTP API endpoints. A remote caller could cause the agent to consume substantial memory before the request was rejected. This vulnerability, CVE-2026-19113, is fixed in Consul 2.0.3 and Consul Enterprise 1.21.17, 1.22.11, and 2.0.3.

CVSS 5.3 · Medium · EPSS 0.4% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • consul

    Versions
    • ≥ 1.3.0, < 2.0.3: Affected (semver)

    Update to 2.0.3

  • consul enterprise

    Versions
    • ≥ 1.3.0, < 2.0.3: Affected; ≥ 1.21.17: Not affected; ≥ 1.22.11: Not affected (semver)

    Update to 1.21.17

  • consul Debian:11

    Versions
    • 1.10.12+dfsg1-1
    • 1.8.7+dfsg1-2
    • 1.8.7+dfsg1-3
    • 1.8.7+dfsg1-4
    • 1.8.7+dfsg1-5
    • 1.8.7+dfsg1-6
    • 1.9.17+dfsg2-1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • consul Ubuntu:18.04:LTS

    Versions
    • 0.6.4~dfsg-3
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • consul Ubuntu:20.04:LTS

    Versions
    • 1.0.7~dfsg1-5ubuntu1
    • 1.4.4~dfsg1-2ubuntu2
    • 1.5.2+dfsg1-6
    • 1.5.2+dfsg1-10
    • 1.5.2+dfsg1-12
    • 1.5.2+dfsg2-14
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • consul Ubuntu:22.04:LTS

    Versions
    • 1.7.4+dfsg1-1
    • 1.8.7+dfsg1-3
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →