p PatchFirst

CVE-2026-21871

CVE-2026-21871 · NiceGUI is vulnerable to XSS via Unescaped URL in ui.navigate.history.push() / replace()

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

NiceGUI is a Python-based UI framework. From versions 2.13.0 to 3.4.1, there is a XSS risk in NiceGUI when developers pass attacker-controlled strings into ui.navigate.history.push() or ui.navigate.history.replace(). These helpers are documented as History API wrappers for updating the browser URL without page reload. However, if the URL argument is embedded into generated JavaScript without proper escaping, a crafted payload can break out of the intended string context and execute arbitrary JavaScript in the victim’s browser. Applications that do not pass untrusted input into ui.navigate.history.push/replace are not affected. This issue has been patched in version 3.5.0.

CVSS 6.1 · Media · EPSS 0,3% · Corrección disponible

Publicación
Actualización

Pila tecnológica: python

Productos y versiones afectados

  • nicegui

    Versiones
    • >= 2.13.0, < 3.5.0: Afectada

    Sin corrección publicada

  • nicegui PyPI

    Versiones
    • 2.13.0
    • 2.14.0
    • 2.14.1
    • 2.15.0
    • 2.16.0
    • 2.16.1
    • 2.17.0
    • 2.18.0
    • 2.19.0
    • 2.20.0
    • 2.21.0
    • 2.21.1
    • 2.22.0
    • 2.22.1
    • 2.22.2
    • 2.23.0
    • 2.23.1
    • 2.23.2
    • 2.23.3
    • 2.24.0
    • 2.24.1
    • 2.24.2
    • 3.0.0
    • 3.0.0rc1
    • 3.0.1
    • 3.0.2
    • 3.0.3
    • 3.0.4
    • 3.1.0
    • 3.2.0
    • 3.3.0
    • 3.3.1
    • 3.4.0
    • 3.4.1
    Intervalos de versiones afectados
    • ECOSYSTEM: ≥ 2.13.0, < 3.5.0

    Actualiza a 3.5.0

Fuentes originales

Comprueba tu servidor →