p PatchFirst

CVE-2026-21871

CVE-2026-21871 · NiceGUI is vulnerable to XSS via Unescaped URL in ui.navigate.history.push() / replace()

This page contains facts from public vulnerability sources. Check the original advisory before updating.

NiceGUI is a Python-based UI framework. From versions 2.13.0 to 3.4.1, there is a XSS risk in NiceGUI when developers pass attacker-controlled strings into ui.navigate.history.push() or ui.navigate.history.replace(). These helpers are documented as History API wrappers for updating the browser URL without page reload. However, if the URL argument is embedded into generated JavaScript without proper escaping, a crafted payload can break out of the intended string context and execute arbitrary JavaScript in the victim’s browser. Applications that do not pass untrusted input into ui.navigate.history.push/replace are not affected. This issue has been patched in version 3.5.0.

CVSS 6.1 · Medium · EPSS 0.3% · Fix available

Published
Updated

Stack: python

Affected products and versions

  • nicegui

    Versions
    • >= 2.13.0, < 3.5.0: Affected

    No fix published

  • nicegui PyPI

    Versions
    • 2.13.0
    • 2.14.0
    • 2.14.1
    • 2.15.0
    • 2.16.0
    • 2.16.1
    • 2.17.0
    • 2.18.0
    • 2.19.0
    • 2.20.0
    • 2.21.0
    • 2.21.1
    • 2.22.0
    • 2.22.1
    • 2.22.2
    • 2.23.0
    • 2.23.1
    • 2.23.2
    • 2.23.3
    • 2.24.0
    • 2.24.1
    • 2.24.2
    • 3.0.0
    • 3.0.0rc1
    • 3.0.1
    • 3.0.2
    • 3.0.3
    • 3.0.4
    • 3.1.0
    • 3.2.0
    • 3.3.0
    • 3.3.1
    • 3.4.0
    • 3.4.1
    Affected ranges
    • ECOSYSTEM: ≥ 2.13.0, < 3.5.0

    Update to 3.5.0

Original sources

Check your server →