p PatchFirst

CVE-2026-22250

CVE-2026-22250 · wlc can skip SSL verification

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

wlc is a Weblate command-line client using Weblate's REST API. Prior to 1.17.0, the SSL verification would be skipped for some crafted URLs. This vulnerability is fixed in 1.17.0.

CVSS 2.5 · Baja · EPSS 0,2% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system · python

Productos y versiones afectados

  • wlc

    Versiones
    • < 1.17.0: Afectada

    Sin corrección publicada

  • wlc Debian:12

    Versiones
    • 1.13-2
    • 1.14-1
    • 1.15-1
    • 1.15-2
    • 1.16.1-1
    • 1.17.2-1
    • 2.0.0-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • wlc Debian:13

    Versiones
    • 1.15-1
    • 1.15-2
    • 1.16.1-1
    • 1.17.2-1
    • 2.0.0-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • wlc Debian:14

    Versiones
    • 1.15-1
    • 1.15-2
    • 1.16.1-1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.17.2-1

    Actualiza a 1.17.2-1

  • wlc PyPI

    Versiones
    • 0.0
    • 0.1
    • 0.10
    • 0.2
    • 0.3
    • 0.4
    • 0.5
    • 0.6
    • 0.7
    • 0.8
    • 0.9
    • 1.0
    • 1.1
    • 1.10
    • 1.11
    • 1.12
    • 1.13
    • 1.14
    • 1.15
    • 1.16.1
    • 1.2
    • 1.3
    • 1.4
    • 1.5
    • 1.6
    • 1.7
    • 1.8
    • 1.9
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.17.0

    Actualiza a 1.17.0

  • wlc Ubuntu:Pro:18.04:LTS

    Versiones
    • 0.8-1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 0.8-1ubuntu0.1~esm1

    Actualiza a 0.8-1ubuntu0.1~esm1

  • wlc Ubuntu:Pro:20.04:LTS

    Versiones
    • 1.1-1
    • 1.2-1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.2-1ubuntu0.20.04.1~esm1

    Actualiza a 1.2-1ubuntu0.20.04.1~esm1

  • wlc Ubuntu:Pro:22.04:LTS

    Versiones
    • 1.2-1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.2-1ubuntu0.22.04.1~esm1

    Actualiza a 1.2-1ubuntu0.22.04.1~esm1

  • wlc Ubuntu:Pro:24.04:LTS

    Versiones
    • 1.13-2
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.13-2ubuntu0.1~esm1

    Actualiza a 1.13-2ubuntu0.1~esm1

  • wlc Ubuntu:25.10

    Versiones
    • 1.15-1
    • 1.15-2
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.15-2ubuntu0.1

    Actualiza a 1.15-2ubuntu0.1

  • wlc Ubuntu:26.10

    Versiones
    • 1.16.1-1
    • 2.0.0-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • wlc Ubuntu:26.04:LTS

    Versiones
    • 1.15-2
    • 1.16.1-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

Fuentes originales

Comprueba tu servidor →