p PatchFirst

CVE-2026-22250

CVE-2026-22250 · wlc can skip SSL verification

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

wlc is a Weblate command-line client using Weblate's REST API. Prior to 1.17.0, the SSL verification would be skipped for some crafted URLs. This vulnerability is fixed in 1.17.0.

CVSS 2.5 · Niedrig · EPSS 0,2% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · python

Betroffene Produkte und Versionen

  • wlc

    Softwareversionen
    • < 1.17.0: Betroffen

    Keine Korrektur veröffentlicht

  • wlc Debian:12

    Softwareversionen
    • 1.13-2
    • 1.14-1
    • 1.15-1
    • 1.15-2
    • 1.16.1-1
    • 1.17.2-1
    • 2.0.0-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • wlc Debian:13

    Softwareversionen
    • 1.15-1
    • 1.15-2
    • 1.16.1-1
    • 1.17.2-1
    • 2.0.0-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • wlc Debian:14

    Softwareversionen
    • 1.15-1
    • 1.15-2
    • 1.16.1-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.17.2-1

    Auf 1.17.2-1 aktualisieren

  • wlc PyPI

    Softwareversionen
    • 0.0
    • 0.1
    • 0.10
    • 0.2
    • 0.3
    • 0.4
    • 0.5
    • 0.6
    • 0.7
    • 0.8
    • 0.9
    • 1.0
    • 1.1
    • 1.10
    • 1.11
    • 1.12
    • 1.13
    • 1.14
    • 1.15
    • 1.16.1
    • 1.2
    • 1.3
    • 1.4
    • 1.5
    • 1.6
    • 1.7
    • 1.8
    • 1.9
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.17.0

    Auf 1.17.0 aktualisieren

  • wlc Ubuntu:Pro:18.04:LTS

    Softwareversionen
    • 0.8-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 0.8-1ubuntu0.1~esm1

    Auf 0.8-1ubuntu0.1~esm1 aktualisieren

  • wlc Ubuntu:Pro:20.04:LTS

    Softwareversionen
    • 1.1-1
    • 1.2-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.2-1ubuntu0.20.04.1~esm1

    Auf 1.2-1ubuntu0.20.04.1~esm1 aktualisieren

  • wlc Ubuntu:Pro:22.04:LTS

    Softwareversionen
    • 1.2-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.2-1ubuntu0.22.04.1~esm1

    Auf 1.2-1ubuntu0.22.04.1~esm1 aktualisieren

  • wlc Ubuntu:Pro:24.04:LTS

    Softwareversionen
    • 1.13-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.13-2ubuntu0.1~esm1

    Auf 1.13-2ubuntu0.1~esm1 aktualisieren

  • wlc Ubuntu:25.10

    Softwareversionen
    • 1.15-1
    • 1.15-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.15-2ubuntu0.1

    Auf 1.15-2ubuntu0.1 aktualisieren

  • wlc Ubuntu:26.10

    Softwareversionen
    • 1.16.1-1
    • 2.0.0-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • wlc Ubuntu:26.04:LTS

    Softwareversionen
    • 1.15-2
    • 1.16.1-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →