CVE-2026-25547
CVE-2026-25547 · Uncontrolled Resource Consumption in @isaacs/brace-expansion
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
@isaacs/brace-expansion is a hybrid CJS/ESM TypeScript fork of brace-expansion. Prior to version 5.0.1, @isaacs/brace-expansion is vulnerable to a denial of service (DoS) issue caused by unbounded brace range expansion. When an attacker provides a pattern containing repeated numeric brace ranges, the library attempts to eagerly generate every possible combination synchronously. Because the expansion grows exponentially, even a small input can consume excessive CPU and memory and may crash the Node.js process. This issue has been patched in version 5.0.1.
CVSS 9.2 · Crítica · EPSS 0,5% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · node
Productos y versiones afectados
brace-expansion
- Versiones
- < 5.0.1: Afectada
Sin corrección publicada
node-brace-expansion Debian:12
- Versiones
- 2.0.1+~1.1.0-1
- 2.0.1+~1.1.0-2
- 2.0.1-2
- 2.0.3+~1.1.2-1
- 2.0.3+~1.1.2-2
- 2.0.3+~1.1.2-3
- 2.1.4+~1.1.2-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-brace-expansion Debian:13
- Versiones
- 2.0.1+~1.1.0-2
- 2.0.3+~1.1.2-1
- 2.0.3+~1.1.2-2
- 2.0.3+~1.1.2-3
- 2.1.4+~1.1.2-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-brace-expansion Debian:14
- Versiones
- 2.0.1+~1.1.0-2
- 2.0.3+~1.1.2-1
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.0.3+~1.1.2-2
Actualiza a 2.0.3+~1.1.2-2
@isaacs/brace-expansion npm
- Intervalos de versiones afectados
- SEMVER: < 5.0.1
Actualiza a 5.0.1
node-brace-expansion Ubuntu:18.04:LTS
- Versiones
- 1.1.8-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-brace-expansion Ubuntu:20.04:LTS
- Versiones
- 1.1.8-1
- 1.1.11-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-brace-expansion Ubuntu:22.04:LTS
- Versiones
- 2.0.0-1
- 2.0.1-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-brace-expansion Ubuntu:24.04:LTS
- Versiones
- 2.0.1-2
- 2.0.1+~1.1.0-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-brace-expansion Ubuntu:25.10
- Versiones
- 2.0.1+~1.1.0-1
- 2.0.1+~1.1.0-2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-brace-expansion Ubuntu:26.10
- Versiones
- 2.0.1+~1.1.0-2
- 2.0.3+~1.1.2-2
- 2.0.3+~1.1.2-3
- 2.1.4+~1.1.2-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-brace-expansion Ubuntu:26.04:LTS
- Versiones
- 2.0.1+~1.1.0-2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada