p PatchFirst

CVE-2026-25547

CVE-2026-25547 · Uncontrolled Resource Consumption in @isaacs/brace-expansion

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

@isaacs/brace-expansion is a hybrid CJS/ESM TypeScript fork of brace-expansion. Prior to version 5.0.1, @isaacs/brace-expansion is vulnerable to a denial of service (DoS) issue caused by unbounded brace range expansion. When an attacker provides a pattern containing repeated numeric brace ranges, the library attempts to eagerly generate every possible combination synchronously. Because the expansion grows exponentially, even a small input can consume excessive CPU and memory and may crash the Node.js process. This issue has been patched in version 5.0.1.

CVSS 9.2 · Kritisch · EPSS 0,5% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · node

Betroffene Produkte und Versionen

  • brace-expansion

    Softwareversionen
    • < 5.0.1: Betroffen

    Keine Korrektur veröffentlicht

  • node-brace-expansion Debian:12

    Softwareversionen
    • 2.0.1+~1.1.0-1
    • 2.0.1+~1.1.0-2
    • 2.0.1-2
    • 2.0.3+~1.1.2-1
    • 2.0.3+~1.1.2-2
    • 2.0.3+~1.1.2-3
    • 2.1.4+~1.1.2-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-brace-expansion Debian:13

    Softwareversionen
    • 2.0.1+~1.1.0-2
    • 2.0.3+~1.1.2-1
    • 2.0.3+~1.1.2-2
    • 2.0.3+~1.1.2-3
    • 2.1.4+~1.1.2-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-brace-expansion Debian:14

    Softwareversionen
    • 2.0.1+~1.1.0-2
    • 2.0.3+~1.1.2-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.0.3+~1.1.2-2

    Auf 2.0.3+~1.1.2-2 aktualisieren

  • @isaacs/brace-expansion npm

    Betroffene Versionsbereiche
    • SEMVER: < 5.0.1

    Auf 5.0.1 aktualisieren

  • node-brace-expansion Ubuntu:18.04:LTS

    Softwareversionen
    • 1.1.8-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-brace-expansion Ubuntu:20.04:LTS

    Softwareversionen
    • 1.1.8-1
    • 1.1.11-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-brace-expansion Ubuntu:22.04:LTS

    Softwareversionen
    • 2.0.0-1
    • 2.0.1-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-brace-expansion Ubuntu:24.04:LTS

    Softwareversionen
    • 2.0.1-2
    • 2.0.1+~1.1.0-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-brace-expansion Ubuntu:25.10

    Softwareversionen
    • 2.0.1+~1.1.0-1
    • 2.0.1+~1.1.0-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-brace-expansion Ubuntu:26.10

    Softwareversionen
    • 2.0.1+~1.1.0-2
    • 2.0.3+~1.1.2-2
    • 2.0.3+~1.1.2-3
    • 2.1.4+~1.1.2-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-brace-expansion Ubuntu:26.04:LTS

    Softwareversionen
    • 2.0.1+~1.1.0-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →