CVE-2026-28356
CVE-2026-28356 · ReDoS in multipart 1.3.0 - `parse_options_header()`
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
multipart is a fast multipart/form-data parser for python. Prior to 1.2.2, 1.3.1 and 1.4.0-dev, the parse_options_header() function in multipart.py uses a regular expression with an ambiguous alternation, which can cause exponential backtracking (ReDoS) when parsing maliciously crafted HTTP or multipart segment headers. This can be abused for denial of service (DoS) attacks against web applications using this library to parse request headers or multipart/form-data streams. The issue is fixed in 1.2.2, 1.3.1 and 1.4.0-dev.
CVSS 7.5 · Alta · EPSS 0,8% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · python
Productos y versiones afectados
multipart
- Versiones
- >= 1.3.0, < 1.3.1: Afectada
- < 1.2.2: Afectada
Sin corrección publicada
multipart Debian:13
- Versiones
- 1.2.1-2
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.2.1-2+deb13u1
Actualiza a 1.2.1-2+deb13u1
multipart Debian:14
- Versiones
- 1.2.1-2
- 1.3.0-1
- 1.3.0-2
- 1.3.0-3
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.3.1-1
Actualiza a 1.3.1-1
multipart PyPI
- Versiones
- 1.3.0
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 1.3.0, < 1.3.1
Actualiza a 1.3.1
multipart PyPI
- Versiones
- 0.1
- 0.1.1
- 0.2
- 0.2.1
- 0.2.2
- 0.2.3
- 0.2.4
- 0.2.5
- 1.0.0
- 1.1.0
- 1.2.0
- 1.2.1
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.2.2
Actualiza a 1.2.2
multipart PyPI
- Versiones
- 0.1
- 0.1.1
- 0.2
- 0.2.1
- 0.2.2
- 0.2.3
- 0.2.4
- 0.2.5
- 1.0.0
- 1.1.0
- 1.2.0
- 1.2.1
- 1.3.0
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.2.2 ∪ ≥ 1.3.0, < 1.3.1
Actualiza a 1.2.2; Actualiza a 1.3.1
multipart Ubuntu:25.10
- Versiones
- 1.2.1-2
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.2.1-2+deb13u1build0.25.10.1
Actualiza a 1.2.1-2+deb13u1build0.25.10.1
multipart Ubuntu:26.04:LTS
- Versiones
- 1.2.1-2
- 1.3.0-3
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.3.0-3ubuntu0.1
Actualiza a 1.3.0-3ubuntu0.1
Fuentes originales
- https://github.com/defnull/multipart/security/advisories/GHSA-p2m9-wcp5-6qw3
- https://access.redhat.com/security/cve/CVE-2026-28356
- https://bugzilla.redhat.com/show_bug.cgi?id=2447059
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-28356.json
- https://access.redhat.com/errata/RHSA-2026:6761
- https://access.redhat.com/errata/RHSA-2026:5809
- https://access.redhat.com/errata/RHSA-2026:6762
- https://access.redhat.com/errata/RHSA-2026:10184
- https://access.redhat.com/errata/RHSA-2026:42644
- https://access.redhat.com/errata/RHSA-2026:37275
- https://nvd.nist.gov/vuln/detail/CVE-2026-28356