CVE-2026-28356
CVE-2026-28356 · ReDoS in multipart 1.3.0 - `parse_options_header()`
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
multipart is a fast multipart/form-data parser for python. Prior to 1.2.2, 1.3.1 and 1.4.0-dev, the parse_options_header() function in multipart.py uses a regular expression with an ambiguous alternation, which can cause exponential backtracking (ReDoS) when parsing maliciously crafted HTTP or multipart segment headers. This can be abused for denial of service (DoS) attacks against web applications using this library to parse request headers or multipart/form-data streams. The issue is fixed in 1.2.2, 1.3.1 and 1.4.0-dev.
CVSS 7.5 · Élevée · EPSS 0,8% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system · python
Produits et versions concernés
multipart
- Versions du logiciel
- >= 1.3.0, < 1.3.1: Concernée
- < 1.2.2: Concernée
Aucun correctif publié
multipart Debian:13
- Versions du logiciel
- 1.2.1-2
- Plages de versions concernées
- ECOSYSTEM: < 1.2.1-2+deb13u1
Mettez à jour vers 1.2.1-2+deb13u1
multipart Debian:14
- Versions du logiciel
- 1.2.1-2
- 1.3.0-1
- 1.3.0-2
- 1.3.0-3
- Plages de versions concernées
- ECOSYSTEM: < 1.3.1-1
Mettez à jour vers 1.3.1-1
multipart PyPI
- Versions du logiciel
- 1.3.0
- Plages de versions concernées
- ECOSYSTEM: ≥ 1.3.0, < 1.3.1
Mettez à jour vers 1.3.1
multipart PyPI
- Versions du logiciel
- 0.1
- 0.1.1
- 0.2
- 0.2.1
- 0.2.2
- 0.2.3
- 0.2.4
- 0.2.5
- 1.0.0
- 1.1.0
- 1.2.0
- 1.2.1
- Plages de versions concernées
- ECOSYSTEM: < 1.2.2
Mettez à jour vers 1.2.2
multipart PyPI
- Versions du logiciel
- 0.1
- 0.1.1
- 0.2
- 0.2.1
- 0.2.2
- 0.2.3
- 0.2.4
- 0.2.5
- 1.0.0
- 1.1.0
- 1.2.0
- 1.2.1
- 1.3.0
- Plages de versions concernées
- ECOSYSTEM: < 1.2.2 ∪ ≥ 1.3.0, < 1.3.1
Mettez à jour vers 1.2.2; Mettez à jour vers 1.3.1
multipart Ubuntu:25.10
- Versions du logiciel
- 1.2.1-2
- Plages de versions concernées
- ECOSYSTEM: < 1.2.1-2+deb13u1build0.25.10.1
Mettez à jour vers 1.2.1-2+deb13u1build0.25.10.1
multipart Ubuntu:26.04:LTS
- Versions du logiciel
- 1.2.1-2
- 1.3.0-3
- Plages de versions concernées
- ECOSYSTEM: < 1.3.0-3ubuntu0.1
Mettez à jour vers 1.3.0-3ubuntu0.1
Sources originales
- https://github.com/defnull/multipart/security/advisories/GHSA-p2m9-wcp5-6qw3
- https://access.redhat.com/security/cve/CVE-2026-28356
- https://bugzilla.redhat.com/show_bug.cgi?id=2447059
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-28356.json
- https://access.redhat.com/errata/RHSA-2026:6761
- https://access.redhat.com/errata/RHSA-2026:5809
- https://access.redhat.com/errata/RHSA-2026:6762
- https://access.redhat.com/errata/RHSA-2026:10184
- https://access.redhat.com/errata/RHSA-2026:42644
- https://access.redhat.com/errata/RHSA-2026:37275
- https://nvd.nist.gov/vuln/detail/CVE-2026-28356