CVE-2026-30962
CVE-2026-30962 · Parse Server has a protected fields bypass via logical query operators
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.5.2-alpha.6 and 8.6.19, the validation for protected fields only checks top-level query keys. By wrapping a query constraint on a protected field inside a logical operator, the check is bypassed entirely. This allows any authenticated user to query on protected fields to extract field values. All Parse Server deployments have default protected fields and are vulnerable. This vulnerability is fixed in 9.5.2-alpha.6 and 8.6.19.
CVSS 7.1 · Alta · EPSS 0,3% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: node
Productos y versiones afectados
parse-server
- Versiones
- >= 9.0.0 < 9.5.2-alpha.6: Afectada
- < 8.6.19: Afectada
Sin corrección publicada
parse-server npm
- Intervalos de versiones afectados
- SEMVER: ≥ 9.0.0, < 9.5.2-alpha.6
Actualiza a 9.5.2-alpha.6
parse-server npm
- Intervalos de versiones afectados
- SEMVER: < 8.6.19
Actualiza a 8.6.19