CVE-2026-30962
CVE-2026-30962 · Parse Server has a protected fields bypass via logical query operators
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.5.2-alpha.6 and 8.6.19, the validation for protected fields only checks top-level query keys. By wrapping a query constraint on a protected field inside a logical operator, the check is bypassed entirely. This allows any authenticated user to query on protected fields to extract field values. All Parse Server deployments have default protected fields and are vulnerable. This vulnerability is fixed in 9.5.2-alpha.6 and 8.6.19.
CVSS 7.1 · Élevée · EPSS 0,3% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: node
Produits et versions concernés
parse-server
- Versions du logiciel
- >= 9.0.0 < 9.5.2-alpha.6: Concernée
- < 8.6.19: Concernée
Aucun correctif publié
parse-server npm
- Plages de versions concernées
- SEMVER: ≥ 9.0.0, < 9.5.2-alpha.6
Mettez à jour vers 9.5.2-alpha.6
parse-server npm
- Plages de versions concernées
- SEMVER: < 8.6.19
Mettez à jour vers 8.6.19