CVE-2026-32248
CVE-2026-32248 · Parse Server: Account takeover via operator injection in authentication data identifier
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.6.0-alpha.12 and 8.6.38, an unauthenticated attacker can take over any user account that was created with an authentication provider that does not validate the format of the user identifier (e.g. anonymous authentication). By sending a crafted login request, the attacker can cause the server to perform a pattern-matching query instead of an exact-match lookup, allowing the attacker to match an existing user and obtain a valid session token for that user's account. Both MongoDB and PostgreSQL database backends are affected. Any Parse Server deployment that allows anonymous authentication (enabled by default) is vulnerable. This vulnerability is fixed in 9.6.0-alpha.12 and 8.6.38.
CVSS 9.3 · Crítica · EPSS 0,6% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: node
Productos y versiones afectados
parse-server
- Versiones
- >= 9.0.0, < 9.6.0-alpha.12: Afectada
- < 8.6.38: Afectada
Sin corrección publicada
parse-server npm
- Intervalos de versiones afectados
- SEMVER: ≥ 9.0.0, < 9.6.0-alpha.12
Actualiza a 9.6.0-alpha.12
parse-server npm
- Intervalos de versiones afectados
- SEMVER: < 8.6.38
Actualiza a 8.6.38