CVE-2026-32248
CVE-2026-32248 · Parse Server: Account takeover via operator injection in authentication data identifier
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.6.0-alpha.12 and 8.6.38, an unauthenticated attacker can take over any user account that was created with an authentication provider that does not validate the format of the user identifier (e.g. anonymous authentication). By sending a crafted login request, the attacker can cause the server to perform a pattern-matching query instead of an exact-match lookup, allowing the attacker to match an existing user and obtain a valid session token for that user's account. Both MongoDB and PostgreSQL database backends are affected. Any Parse Server deployment that allows anonymous authentication (enabled by default) is vulnerable. This vulnerability is fixed in 9.6.0-alpha.12 and 8.6.38.
CVSS 9.3 · Critique · EPSS 0,6% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: node
Produits et versions concernés
parse-server
- Versions du logiciel
- >= 9.0.0, < 9.6.0-alpha.12: Concernée
- < 8.6.38: Concernée
Aucun correctif publié
parse-server npm
- Plages de versions concernées
- SEMVER: ≥ 9.0.0, < 9.6.0-alpha.12
Mettez à jour vers 9.6.0-alpha.12
parse-server npm
- Plages de versions concernées
- SEMVER: < 8.6.38
Mettez à jour vers 8.6.38