p PatchFirst

CVE-2026-32597

CVE-2026-32597 · PyJWT accepts unknown `crit` header extensions (RFC 7515 §4.1.11 MUST violation)

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Esta página muestra una selección de datos de las fuentes. Consulte los avisos enlazados para ver la descripción completa y las versiones afectadas.

PyJWT is a JSON Web Token implementation in Python. Prior to 2.12.0, PyJWT does not validate the crit (Critical) Header Parameter defined in RFC 7515 §4.1.11. When a JWS token contains a crit array listing extensions that PyJWT does not understand, the library accepts the token instead of rejecting it. This violates the MUST requirement in the RFC. This vulnerability is fixed in 2.12.0.

CVSS 7.5 · Alta · EPSS 0,3% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system · python

Productos y versiones afectados

  • pyjwt

    Versiones
    • < 2.12.0: Afectada

    Sin corrección publicada

  • pyjwt Debian:12

    Versiones
    • 2.6.0-1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.6.0-1+deb12u1

    Actualiza a 2.6.0-1+deb12u1

  • pyjwt Debian:13

    Versiones
    • 2.10.1-2
    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.10.1-2+deb13u1

    Actualiza a 2.10.1-2+deb13u1

  • pyjwt Debian:14

    Versiones
    • 2.10.1-2
    • 2.10.1-3
    • 2.10.1-4
    • 2.11.0-2
    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.12.1-1

    Actualiza a 2.12.1-1

  • pyjwt PyPI

    Versiones
    • 0.1.1
    • 0.1.2
    • 0.1.3
    • 0.1.4
    • 0.1.5
    • 0.1.6
    • 0.1.7
    • 0.1.8
    • 0.1.9
    • 0.2.0
    • 0.2.1
    • 0.2.3
    • 0.3.0
    • 0.3.1
    • 0.3.2
    • 0.4.0
    • 0.4.1
    • 0.4.2
    • 0.4.3
    • 1.0.0
    • 1.0.1
    • 1.1.0
    • 1.3.0
    • 1.4.0
    • 1.4.1
    • 1.4.2
    • 1.5.0
    • 1.5.1
    • 1.5.2
    • 1.5.3
    • 1.6.0
    • 1.6.1
    • 1.6.3
    • 1.6.4
    • 1.7.0
    • 1.7.1
    • 2.0.0
    • 2.0.0a1
    • 2.0.0a2
    • 2.0.1
    • 2.1.0
    • 2.10.0
    • 2.10.1
    • 2.11.0
    • 2.2.0
    • 2.3.0
    • 2.4.0
    • 2.5.0
    • 2.6.0
    • 2.7.0
    • 2.8.0
    • 2.9.0
    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.12.0

    Actualiza a 2.12.0

  • pyjwt Ubuntu:Pro:16.04:LTS

    Versiones
    • 1.0.0-0ubuntu1
    • 1.3.0-1
    • 1.3.0-1ubuntu0.1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.3.0-1ubuntu0.1+esm1

    Actualiza a 1.3.0-1ubuntu0.1+esm1

  • pyjwt Ubuntu:Pro:18.04:LTS

    Versiones
    • 1.4.2-1.1
    • 1.5.3+ds1-1
    • 1.5.3+ds1-1ubuntu0.1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.5.3+ds1-1ubuntu0.1+esm1

    Actualiza a 1.5.3+ds1-1ubuntu0.1+esm1

  • pyjwt Ubuntu:Pro:20.04:LTS

    Versiones
    • 1.7.0-2
    • 1.7.1-1
    • 1.7.1-2ubuntu1
    • 1.7.1-2ubuntu2
    • 1.7.1-2ubuntu2.1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.7.1-2ubuntu2.1+esm1

    Actualiza a 1.7.1-2ubuntu2.1+esm1

  • pyjwt Ubuntu:22.04:LTS

    Versiones
    • 1.7.1-2ubuntu2
    • 2.1.0-1
    • 2.3.0-1
    • 2.3.0-1ubuntu0.1
    • 2.3.0-1ubuntu0.2
    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.3.0-1ubuntu0.3

    Actualiza a 2.3.0-1ubuntu0.3

  • pyjwt Ubuntu:24.04:LTS

    Versiones
    • 2.7.0-1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.7.0-1ubuntu0.1

    Actualiza a 2.7.0-1ubuntu0.1

  • pyjwt Ubuntu:25.10

    Versiones
    • 2.10.1-2
    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.10.1-2ubuntu0.1

    Actualiza a 2.10.1-2ubuntu0.1

Fuentes originales

Comprueba tu servidor →