CVE-2026-32597
CVE-2026-32597 · PyJWT accepts unknown `crit` header extensions (RFC 7515 §4.1.11 MUST violation)
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
Cette page présente une partie des faits des sources. Consultez les avis liés pour la description complète et les versions concernées.
PyJWT is a JSON Web Token implementation in Python. Prior to 2.12.0, PyJWT does not validate the crit (Critical) Header Parameter defined in RFC 7515 §4.1.11. When a JWS token contains a crit array listing extensions that PyJWT does not understand, the library accepts the token instead of rejecting it. This violates the MUST requirement in the RFC. This vulnerability is fixed in 2.12.0.
CVSS 7.5 · Élevée · EPSS 0,3% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system · python
Produits et versions concernés
pyjwt
- Versions du logiciel
- < 2.12.0: Concernée
Aucun correctif publié
pyjwt Debian:12
- Versions du logiciel
- 2.6.0-1
- Plages de versions concernées
- ECOSYSTEM: < 2.6.0-1+deb12u1
Mettez à jour vers 2.6.0-1+deb12u1
pyjwt Debian:13
- Versions du logiciel
- 2.10.1-2
- Plages de versions concernées
- ECOSYSTEM: < 2.10.1-2+deb13u1
Mettez à jour vers 2.10.1-2+deb13u1
pyjwt Debian:14
- Versions du logiciel
- 2.10.1-2
- 2.10.1-3
- 2.10.1-4
- 2.11.0-2
- Plages de versions concernées
- ECOSYSTEM: < 2.12.1-1
Mettez à jour vers 2.12.1-1
pyjwt PyPI
- Versions du logiciel
- 0.1.1
- 0.1.2
- 0.1.3
- 0.1.4
- 0.1.5
- 0.1.6
- 0.1.7
- 0.1.8
- 0.1.9
- 0.2.0
- 0.2.1
- 0.2.3
- 0.3.0
- 0.3.1
- 0.3.2
- 0.4.0
- 0.4.1
- 0.4.2
- 0.4.3
- 1.0.0
- 1.0.1
- 1.1.0
- 1.3.0
- 1.4.0
- 1.4.1
- 1.4.2
- 1.5.0
- 1.5.1
- 1.5.2
- 1.5.3
- 1.6.0
- 1.6.1
- 1.6.3
- 1.6.4
- 1.7.0
- 1.7.1
- 2.0.0
- 2.0.0a1
- 2.0.0a2
- 2.0.1
- 2.1.0
- 2.10.0
- 2.10.1
- 2.11.0
- 2.2.0
- 2.3.0
- 2.4.0
- 2.5.0
- 2.6.0
- 2.7.0
- 2.8.0
- 2.9.0
- Plages de versions concernées
- ECOSYSTEM: < 2.12.0
Mettez à jour vers 2.12.0
pyjwt Ubuntu:Pro:16.04:LTS
- Versions du logiciel
- 1.0.0-0ubuntu1
- 1.3.0-1
- 1.3.0-1ubuntu0.1
- Plages de versions concernées
- ECOSYSTEM: < 1.3.0-1ubuntu0.1+esm1
Mettez à jour vers 1.3.0-1ubuntu0.1+esm1
pyjwt Ubuntu:Pro:18.04:LTS
- Versions du logiciel
- 1.4.2-1.1
- 1.5.3+ds1-1
- 1.5.3+ds1-1ubuntu0.1
- Plages de versions concernées
- ECOSYSTEM: < 1.5.3+ds1-1ubuntu0.1+esm1
Mettez à jour vers 1.5.3+ds1-1ubuntu0.1+esm1
pyjwt Ubuntu:Pro:20.04:LTS
- Versions du logiciel
- 1.7.0-2
- 1.7.1-1
- 1.7.1-2ubuntu1
- 1.7.1-2ubuntu2
- 1.7.1-2ubuntu2.1
- Plages de versions concernées
- ECOSYSTEM: < 1.7.1-2ubuntu2.1+esm1
Mettez à jour vers 1.7.1-2ubuntu2.1+esm1
pyjwt Ubuntu:22.04:LTS
- Versions du logiciel
- 1.7.1-2ubuntu2
- 2.1.0-1
- 2.3.0-1
- 2.3.0-1ubuntu0.1
- 2.3.0-1ubuntu0.2
- Plages de versions concernées
- ECOSYSTEM: < 2.3.0-1ubuntu0.3
Mettez à jour vers 2.3.0-1ubuntu0.3
pyjwt Ubuntu:24.04:LTS
- Versions du logiciel
- 2.7.0-1
- Plages de versions concernées
- ECOSYSTEM: < 2.7.0-1ubuntu0.1
Mettez à jour vers 2.7.0-1ubuntu0.1
pyjwt Ubuntu:25.10
- Versions du logiciel
- 2.10.1-2
- Plages de versions concernées
- ECOSYSTEM: < 2.10.1-2ubuntu0.1
Mettez à jour vers 2.10.1-2ubuntu0.1
Sources originales
- https://github.com/jpadilla/pyjwt/security/advisories/GHSA-752w-5fwx-jx9f
- https://lists.debian.org/debian-lts-announce/2026/05/msg00008.html
- https://access.redhat.com/security/cve/CVE-2026-32597
- https://bugzilla.redhat.com/show_bug.cgi?id=2447194
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-32597.json
- https://access.redhat.com/errata/RHSA-2026:13512
- https://access.redhat.com/errata/RHSA-2026:13508
- https://access.redhat.com/errata/RHSA-2026:17083
- https://access.redhat.com/errata/RHSA-2026:13916
- https://access.redhat.com/errata/RHSA-2026:19138
- https://access.redhat.com/errata/RHSA-2026:12176
- https://access.redhat.com/errata/RHSA-2026:22330
- https://access.redhat.com/errata/RHSA-2026:21517
- https://access.redhat.com/errata/RHSA-2026:21431
- https://access.redhat.com/errata/RHSA-2026:13672
- https://access.redhat.com/errata/RHSA-2026:19355
- https://access.redhat.com/errata/RHSA-2026:8748
- https://access.redhat.com/errata/RHSA-2026:8746
- https://access.redhat.com/errata/RHSA-2026:8747
- https://access.redhat.com/errata/RHSA-2026:13553
- https://access.redhat.com/errata/RHSA-2026:13545
- https://access.redhat.com/errata/RHSA-2026:10140
- https://access.redhat.com/errata/RHSA-2026:10141
- https://nvd.nist.gov/vuln/detail/CVE-2026-32597