CVE-2026-32875
CVE-2026-32875 · UltraJSON has an integer overflow handling large indent leads to buffer overflow or infinite loop
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
UltraJSON is a fast JSON encoder and decoder written in pure C with bindings for Python 3.7+. Versions 5.10 through 5.11.0 are vulnerable to buffer overflow or infinite loop through large indent handling. ujson.dumps() crashes the Python interpreter (segmentation fault) when the product of the indent parameter and the nested depth of the input exceeds INT32_MAX. It can also get stuck in an infinite loop if the indent is a large negative number. Both are caused by an integer overflow/underflow whilst calculating how much memory to reserve for indentation. And both can be used to achieve denial of service. To be vulnerable, a service must call ujson.dump()/ujson.dumps()/ujson.encode() whilst giving untrusted users control over the indent parameter and not restrict that indentation to reasonably small non-negative values. A service may also be vulnerable to the infinite loop if it uses a fixed negative indent. An underflow always occurs for any negative indent when the input data is at least one level nested but, for small negative indents, the underflow is usually accidentally rectified by another overflow. This issue has been fixed in version 5.12.0.
CVSS 7.5 · Alta · EPSS 0,5% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · python
Productos y versiones afectados
ultrajson
- Versiones
- >= 5.1.0, < 5.12.0: Afectada
Sin corrección publicada
ujson Debian:12
- Versiones
- 5.10.0-1
- 5.11.0-1
- 5.11.0-2
- 5.11.0-3
- 5.13.0-1
- 5.7.0-1
- 5.8.0-1
- 5.9.0-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
ujson Debian:13
- Versiones
- 5.10.0-1
- 5.11.0-1
- 5.11.0-2
- 5.11.0-3
- 5.13.0-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
ujson Debian:14
- Versiones
- 5.10.0-1
- 5.11.0-1
- 5.11.0-2
- 5.11.0-3
- Intervalos de versiones afectados
- ECOSYSTEM: < 5.13.0-1
Actualiza a 5.13.0-1
ujson PyPI
- Versiones
- 5.1.0
- 5.10.0
- 5.11.0
- 5.2.0
- 5.3.0
- 5.4.0
- 5.5.0
- 5.6.0
- 5.7.0
- 5.8.0
- 5.9.0
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 5.1.0, < 5.12.0
Actualiza a 5.12.0
ujson Ubuntu:Pro:22.04:LTS
- Versiones
- 4.0.2-1
- 4.0.2-1build1
- 4.2.0-1
- 5.1.0-1
- 5.1.0-1build1
- 5.1.0-1ubuntu0.1~esm1
- Intervalos de versiones afectados
- ECOSYSTEM: < 5.1.0-1ubuntu0.1~esm2
Actualiza a 5.1.0-1ubuntu0.1~esm2
ujson Ubuntu:Pro:24.04:LTS
- Versiones
- 5.8.0-1
- 5.8.0-1build1
- 5.9.0-1
- 5.9.0-1build1
- Intervalos de versiones afectados
- ECOSYSTEM: < 5.9.0-1ubuntu0.1~esm1
Actualiza a 5.9.0-1ubuntu0.1~esm1
ujson Ubuntu:25.10
- Versiones
- 5.10.0-1build2
- Intervalos de versiones afectados
- ECOSYSTEM: < 5.10.0-1ubuntu0.1
Actualiza a 5.10.0-1ubuntu0.1
ujson Ubuntu:26.10
- Versiones
- 5.11.0-3build1
- 5.13.0-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
ujson Ubuntu:26.04:LTS
- Versiones
- 5.10.0-1build2
- 5.10.0-1build3
- 5.11.0-3
- 5.11.0-3build1
- Intervalos de versiones afectados
- ECOSYSTEM: < 5.11.0-3ubuntu0.1
Actualiza a 5.11.0-3ubuntu0.1
Fuentes originales
- https://github.com/ultrajson/ultrajson/security/advisories/GHSA-c8rr-9gxc-jprv
- https://github.com/ultrajson/ultrajson/issues/700
- https://github.com/ultrajson/ultrajson/commit/486bd4553dc471a1de11613bc7347a6b318e37ea
- https://access.redhat.com/security/cve/CVE-2026-32875
- https://bugzilla.redhat.com/show_bug.cgi?id=2449400
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-32875.json
- https://nvd.nist.gov/vuln/detail/CVE-2026-32875