p PatchFirst

CVE-2026-32875

CVE-2026-32875 · UltraJSON has an integer overflow handling large indent leads to buffer overflow or infinite loop

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

UltraJSON is a fast JSON encoder and decoder written in pure C with bindings for Python 3.7+. Versions 5.10 through 5.11.0 are vulnerable to buffer overflow or infinite loop through large indent handling. ujson.dumps() crashes the Python interpreter (segmentation fault) when the product of the indent parameter and the nested depth of the input exceeds INT32_MAX. It can also get stuck in an infinite loop if the indent is a large negative number. Both are caused by an integer overflow/underflow whilst calculating how much memory to reserve for indentation. And both can be used to achieve denial of service. To be vulnerable, a service must call ujson.dump()/ujson.dumps()/ujson.encode() whilst giving untrusted users control over the indent parameter and not restrict that indentation to reasonably small non-negative values. A service may also be vulnerable to the infinite loop if it uses a fixed negative indent. An underflow always occurs for any negative indent when the input data is at least one level nested but, for small negative indents, the underflow is usually accidentally rectified by another overflow. This issue has been fixed in version 5.12.0.

CVSS 7.5 · Élevée · EPSS 0,5% · Correctif disponible

Publication
Mise à jour

Pile logicielle: system · python

Produits et versions concernés

  • ultrajson

    Versions du logiciel
    • >= 5.1.0, < 5.12.0: Concernée

    Aucun correctif publié

  • ujson Debian:12

    Versions du logiciel
    • 5.10.0-1
    • 5.11.0-1
    • 5.11.0-2
    • 5.11.0-3
    • 5.13.0-1
    • 5.7.0-1
    • 5.8.0-1
    • 5.9.0-1
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • ujson Debian:13

    Versions du logiciel
    • 5.10.0-1
    • 5.11.0-1
    • 5.11.0-2
    • 5.11.0-3
    • 5.13.0-1
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • ujson Debian:14

    Versions du logiciel
    • 5.10.0-1
    • 5.11.0-1
    • 5.11.0-2
    • 5.11.0-3
    Plages de versions concernées
    • ECOSYSTEM: < 5.13.0-1

    Mettez à jour vers 5.13.0-1

  • ujson PyPI

    Versions du logiciel
    • 5.1.0
    • 5.10.0
    • 5.11.0
    • 5.2.0
    • 5.3.0
    • 5.4.0
    • 5.5.0
    • 5.6.0
    • 5.7.0
    • 5.8.0
    • 5.9.0
    Plages de versions concernées
    • ECOSYSTEM: ≥ 5.1.0, < 5.12.0

    Mettez à jour vers 5.12.0

  • ujson Ubuntu:Pro:22.04:LTS

    Versions du logiciel
    • 4.0.2-1
    • 4.0.2-1build1
    • 4.2.0-1
    • 5.1.0-1
    • 5.1.0-1build1
    • 5.1.0-1ubuntu0.1~esm1
    Plages de versions concernées
    • ECOSYSTEM: < 5.1.0-1ubuntu0.1~esm2

    Mettez à jour vers 5.1.0-1ubuntu0.1~esm2

  • ujson Ubuntu:Pro:24.04:LTS

    Versions du logiciel
    • 5.8.0-1
    • 5.8.0-1build1
    • 5.9.0-1
    • 5.9.0-1build1
    Plages de versions concernées
    • ECOSYSTEM: < 5.9.0-1ubuntu0.1~esm1

    Mettez à jour vers 5.9.0-1ubuntu0.1~esm1

  • ujson Ubuntu:25.10

    Versions du logiciel
    • 5.10.0-1build2
    Plages de versions concernées
    • ECOSYSTEM: < 5.10.0-1ubuntu0.1

    Mettez à jour vers 5.10.0-1ubuntu0.1

  • ujson Ubuntu:26.10

    Versions du logiciel
    • 5.11.0-3build1
    • 5.13.0-1
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • ujson Ubuntu:26.04:LTS

    Versions du logiciel
    • 5.10.0-1build2
    • 5.10.0-1build3
    • 5.11.0-3
    • 5.11.0-3build1
    Plages de versions concernées
    • ECOSYSTEM: < 5.11.0-3ubuntu0.1

    Mettez à jour vers 5.11.0-3ubuntu0.1

Sources originales

Vérifiez votre serveur →