p PatchFirst

CVE-2026-33155

CVE-2026-33155 · DeepDiff has Memory Exhaustion DoS through SAFE_TO_IMPORT

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

DeepDiff is a project focused on Deep Difference and search of any Python data. From version 5.0.0 to before version 8.6.2, the pickle unpickler _RestrictedUnpickler validates which classes can be loaded but does not limit their constructor arguments. A few of the types in SAFE_TO_IMPORT have constructors that allocate memory proportional to their input (builtins.bytes, builtins.list, builtins.range). A 40-byte pickle payload can force 10+ GB of memory, which crashes applications that load delta objects or call pickle_load with untrusted data. This issue has been patched in version 8.6.2.

CVSS 8.7 · Alta · EPSS 0,5% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system · python

Productos y versiones afectados

  • deepdiff

    Versiones
    • >= 5.0.0, < 8.6.2: Afectada

    Sin corrección publicada

  • deepdiff Debian:12

    Versiones
    • 6.2.2-1
    • 6.7.1-1
    • 6.7.1-2
    • 8.1.1-1
    • 8.1.1-2
    • 8.1.1-3
    • 8.1.1-4
    • 8.6.1-1
    • 9.0.0-1
    • 9.0.0-2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • deepdiff Debian:13

    Versiones
    • 8.1.1-4
    Intervalos de versiones afectados
    • ECOSYSTEM: < 8.1.1-4+deb13u1

    Actualiza a 8.1.1-4+deb13u1

  • deepdiff Debian:14

    Versiones
    • 8.1.1-4
    • 8.6.1-1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 9.0.0-1

    Actualiza a 9.0.0-1

  • deepdiff PyPI

    Versiones
    • 5.0.0
    • 5.0.1
    • 5.0.2
    • 5.2.0
    • 5.2.1
    • 5.2.2
    • 5.2.3
    • 5.3.0
    • 5.5.0
    • 5.6.0
    • 5.7.0
    • 5.8.0
    • 5.8.1
    • 6.2.1
    • 6.2.2
    • 6.2.3
    • 6.3.0
    • 6.3.1
    • 6.4.0
    • 6.4.1
    • 6.5.0
    • 6.6.0
    • 6.6.1
    • 6.7.0
    • 6.7.1
    • 7.0.0
    • 7.0.1
    • 8.0.0
    • 8.0.1
    • 8.1.0
    • 8.1.1
    • 8.2.0
    • 8.3.0
    • 8.4.0
    • 8.4.1
    • 8.4.2
    • 8.5.0
    • 8.6.0
    • 8.6.1
    Intervalos de versiones afectados
    • ECOSYSTEM: ≥ 5.0.0, < 8.6.2

    Actualiza a 8.6.2

  • deepdiff Ubuntu:20.04:LTS

    Versiones
    • 3.3.0-1
    • 3.3.0-2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • deepdiff Ubuntu:22.04:LTS

    Versiones
    • 3.3.0-2
    • 3.3.0-2ubuntu1
    • 3.3.0-3
    • 5.6.0-2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • deepdiff Ubuntu:24.04:LTS

    Versiones
    • 6.2.2-1
    • 6.7.1-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • deepdiff Ubuntu:25.10

    Versiones
    • 8.1.1-3
    • 8.1.1-4
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • deepdiff Ubuntu:26.10

    Versiones
    • 8.6.1-1
    • 9.0.0-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • deepdiff Ubuntu:26.04:LTS

    Versiones
    • 8.1.1-4
    • 8.6.1-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

Fuentes originales

Comprueba tu servidor →