p PatchFirst

CVE-2026-33155

CVE-2026-33155 · DeepDiff has Memory Exhaustion DoS through SAFE_TO_IMPORT

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

DeepDiff is a project focused on Deep Difference and search of any Python data. From version 5.0.0 to before version 8.6.2, the pickle unpickler _RestrictedUnpickler validates which classes can be loaded but does not limit their constructor arguments. A few of the types in SAFE_TO_IMPORT have constructors that allocate memory proportional to their input (builtins.bytes, builtins.list, builtins.range). A 40-byte pickle payload can force 10+ GB of memory, which crashes applications that load delta objects or call pickle_load with untrusted data. This issue has been patched in version 8.6.2.

CVSS 8.7 · Hoch · EPSS 0,5% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · python

Betroffene Produkte und Versionen

  • deepdiff

    Softwareversionen
    • >= 5.0.0, < 8.6.2: Betroffen

    Keine Korrektur veröffentlicht

  • deepdiff Debian:12

    Softwareversionen
    • 6.2.2-1
    • 6.7.1-1
    • 6.7.1-2
    • 8.1.1-1
    • 8.1.1-2
    • 8.1.1-3
    • 8.1.1-4
    • 8.6.1-1
    • 9.0.0-1
    • 9.0.0-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • deepdiff Debian:13

    Softwareversionen
    • 8.1.1-4
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 8.1.1-4+deb13u1

    Auf 8.1.1-4+deb13u1 aktualisieren

  • deepdiff Debian:14

    Softwareversionen
    • 8.1.1-4
    • 8.6.1-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 9.0.0-1

    Auf 9.0.0-1 aktualisieren

  • deepdiff PyPI

    Softwareversionen
    • 5.0.0
    • 5.0.1
    • 5.0.2
    • 5.2.0
    • 5.2.1
    • 5.2.2
    • 5.2.3
    • 5.3.0
    • 5.5.0
    • 5.6.0
    • 5.7.0
    • 5.8.0
    • 5.8.1
    • 6.2.1
    • 6.2.2
    • 6.2.3
    • 6.3.0
    • 6.3.1
    • 6.4.0
    • 6.4.1
    • 6.5.0
    • 6.6.0
    • 6.6.1
    • 6.7.0
    • 6.7.1
    • 7.0.0
    • 7.0.1
    • 8.0.0
    • 8.0.1
    • 8.1.0
    • 8.1.1
    • 8.2.0
    • 8.3.0
    • 8.4.0
    • 8.4.1
    • 8.4.2
    • 8.5.0
    • 8.6.0
    • 8.6.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 5.0.0, < 8.6.2

    Auf 8.6.2 aktualisieren

  • deepdiff Ubuntu:20.04:LTS

    Softwareversionen
    • 3.3.0-1
    • 3.3.0-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • deepdiff Ubuntu:22.04:LTS

    Softwareversionen
    • 3.3.0-2
    • 3.3.0-2ubuntu1
    • 3.3.0-3
    • 5.6.0-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • deepdiff Ubuntu:24.04:LTS

    Softwareversionen
    • 6.2.2-1
    • 6.7.1-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • deepdiff Ubuntu:25.10

    Softwareversionen
    • 8.1.1-3
    • 8.1.1-4
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • deepdiff Ubuntu:26.10

    Softwareversionen
    • 8.6.1-1
    • 9.0.0-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • deepdiff Ubuntu:26.04:LTS

    Softwareversionen
    • 8.1.1-4
    • 8.6.1-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →