p PatchFirst

CVE-2026-33409

CVE-2026-33409 · Parse Server: Auth provider validation bypass on login via partial authData

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.52 and 9.6.0-alpha.41, an authentication bypass vulnerability allows an attacker to log in as any user who has linked a third-party authentication provider, without knowing the user's credentials. The attacker only needs to know the user's provider ID to gain full access to their account, including a valid session token. This affects Parse Server deployments where the server option allowExpiredAuthDataToken is set to true. The default value is false. This issue has been patched in versions 8.6.52 and 9.6.0-alpha.41.

CVSS 7.0 · Alta · EPSS 0,5% · Corrección disponible

Publicación
Actualización

Pila tecnológica: node

Productos y versiones afectados

  • parse-server

    Versiones
    • < 8.6.52: Afectada
    • >= 9.0.0, < 9.6.0-alpha.41: Afectada

    Sin corrección publicada

  • parse-server npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 9.0.0, < 9.6.0-alpha.41

    Actualiza a 9.6.0-alpha.41

  • parse-server npm

    Intervalos de versiones afectados
    • SEMVER: < 8.6.52

    Actualiza a 8.6.52

Fuentes originales

Comprueba tu servidor →