p PatchFirst

CVE-2026-33409

CVE-2026-33409 · Parse Server: Auth provider validation bypass on login via partial authData

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.52 and 9.6.0-alpha.41, an authentication bypass vulnerability allows an attacker to log in as any user who has linked a third-party authentication provider, without knowing the user's credentials. The attacker only needs to know the user's provider ID to gain full access to their account, including a valid session token. This affects Parse Server deployments where the server option allowExpiredAuthDataToken is set to true. The default value is false. This issue has been patched in versions 8.6.52 and 9.6.0-alpha.41.

CVSS 7.0 · Élevée · EPSS 0,5% · Correctif disponible

Publication
Mise à jour

Pile logicielle: node

Produits et versions concernés

  • parse-server

    Versions du logiciel
    • < 8.6.52: Concernée
    • >= 9.0.0, < 9.6.0-alpha.41: Concernée

    Aucun correctif publié

  • parse-server npm

    Plages de versions concernées
    • SEMVER: ≥ 9.0.0, < 9.6.0-alpha.41

    Mettez à jour vers 9.6.0-alpha.41

  • parse-server npm

    Plages de versions concernées
    • SEMVER: < 8.6.52

    Mettez à jour vers 8.6.52

Sources originales

Vérifiez votre serveur →