p PatchFirst

CVE-2026-34077

CVE-2026-34077 · React Router vulnerable to Denial of Service via reflected user input in single-fetch

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

React Router is a router for React. In versions 7.7.0 through 7.13.1, when using React Router's unstable React Server Components (RSC) APIs, there is a potential client-side Cross-Site Scripting (XSS) vulnerability in the RSC redirect handling if redirects come from untrusted sources. This does not impact applications that are not using the unstable RSC APIs in React Router. This is patched in version 7.13.2.

CVSS 7.5 · Alta · EPSS 0,3% · Corrección disponible

Publicación
Actualización

Pila tecnológica: node

Productos y versiones afectados

  • react-router

    Versiones
    • >= 7.0.0, < 7.14.0: Afectada

    Sin corrección publicada

  • turbo-stream

    Versiones
    • < 3.0.0: Afectada

    Sin corrección publicada

  • react-router npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 7.0.0, < 7.14.0

    Actualiza a 7.14.0

  • turbo-stream npm

    Intervalos de versiones afectados
    • SEMVER: < 3.0.0

    Actualiza a 3.0.0

Fuentes originales

Comprueba tu servidor →