p PatchFirst

CVE-2026-34077

CVE-2026-34077 · React Router vulnerable to Denial of Service via reflected user input in single-fetch

This page contains facts from public vulnerability sources. Check the original advisory before updating.

React Router is a router for React. In versions 7.7.0 through 7.13.1, when using React Router's unstable React Server Components (RSC) APIs, there is a potential client-side Cross-Site Scripting (XSS) vulnerability in the RSC redirect handling if redirects come from untrusted sources. This does not impact applications that are not using the unstable RSC APIs in React Router. This is patched in version 7.13.2.

CVSS 7.5 · High · EPSS 0.3% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • react-router

    Versions
    • >= 7.0.0, < 7.14.0: Affected

    No fix published

  • turbo-stream

    Versions
    • < 3.0.0: Affected

    No fix published

  • react-router npm

    Affected ranges
    • SEMVER: ≥ 7.0.0, < 7.14.0

    Update to 7.14.0

  • turbo-stream npm

    Affected ranges
    • SEMVER: < 3.0.0

    Update to 3.0.0

Original sources

Check your server →