CVE-2026-41608
CVE-2026-41608 · Apache Thrift: Unbounded Zlib Decompression in Python THeaderTransport
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Improper Handling of Highly Compressed Data (Data Amplification) vulnerability in Apache Thrift Python bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue.
CVSS 7.5 · Alta · EPSS 1,0% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · python
Productos y versiones afectados
apache thrift
- Versiones
- ≥ 0, < 0.24.0: Afectada (semver)
Actualiza a 0.24.0
thrift Debian:12
- Versiones
- 0.17.0-2
- 0.17.0-3
- 0.17.0-4
- 0.18.1-1
- 0.18.1-2
- 0.19.0-1
- 0.19.0-2
- 0.19.0-2.1
- 0.19.0-2.1~exp1
- 0.19.0-3
- 0.19.0-4
- 0.20.0-1
- 0.22.0-1
- 0.22.0-2
- 0.22.0-3
- 0.22.0-4
- 0.23.0-1
- 0.23.0-2
- 0.23.0-3
- 0.24.0-1
- 0.24.0-2
- 0.24.0-3
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
thrift Debian:13
- Versiones
- 0.19.0-4
- 0.20.0-1
- 0.22.0-1
- 0.22.0-2
- 0.22.0-3
- 0.22.0-4
- 0.23.0-1
- 0.23.0-2
- 0.23.0-3
- 0.24.0-1
- 0.24.0-2
- 0.24.0-3
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
thrift Debian:14
- Versiones
- 0.19.0-4
- 0.20.0-1
- 0.22.0-1
- 0.22.0-2
- 0.22.0-3
- 0.22.0-4
- 0.23.0-1
- 0.23.0-2
- 0.23.0-3
- 0.24.0-1
- Intervalos de versiones afectados
- ECOSYSTEM: < 0.24.0-2
Actualiza a 0.24.0-2
thrift PyPI
- Versiones
- 0.10.0
- 0.11.0
- 0.13.0
- 0.14.0
- 0.14.1
- 0.14.2
- 0.15.0
- 0.16.0
- 0.20.0
- 0.21.0
- 0.22.0
- 0.23.0
- 0.8.0
- 0.9.0
- 0.9.1
- 0.9.2
- 0.9.3
- Intervalos de versiones afectados
- ECOSYSTEM: < 0.24.0
Actualiza a 0.24.0
thrift Ubuntu:20.04:LTS
- Versiones
- 0.11.0-6
- 0.13.0-2build1
- 0.13.0-2build2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
thrift Ubuntu:22.04:LTS
- Versiones
- 0.13.0-6ubuntu1
- 0.13.0-6ubuntu2
- 0.13.0-6ubuntu3
- 0.13.0-7
- 0.16.0-2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
thrift Ubuntu:24.04:LTS
- Versiones
- 0.17.0-4
- 0.19.0-2
- 0.19.0-2build1
- 0.19.0-2.1build4
- 0.19.0-2.1build5
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
thrift Ubuntu:26.10
- Versiones
- 0.22.0-3ubuntu1
- 0.23.0-3
- 0.23.0-3ubuntu1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
thrift Ubuntu:26.04:LTS
- Versiones
- 0.19.0-4build1
- 0.22.0-3
- 0.22.0-3ubuntu1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada