p PatchFirst

CVE-2026-42224

CVE-2026-42224 · ipl/web is vulnerable to reflected XSS by malformed search requests

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

ipl/web is a set of common web components for php projects. Prior to versions 0.13.1 and 0.10.3, the vulnerability allows an attacker to inject malicious Javascript into a victim's browser to run it in the context of Icinga Web. The victim needs to visit a specifically prepared website and may have no immediate chance to notice any wrongdoing. This issue has been patched in versions 0.13.1 and 0.10.3.

CVSS 7.6 · Alta · EPSS 0,3% · Corrección disponible

Publicación
Actualización

Pila tecnológica: php

Productos y versiones afectados

  • ipl-web

    Versiones
    • >= 0.11.0, < 0.13.1: Afectada
    • < 0.10.3: Afectada

    Sin corrección publicada

  • ipl/web Packagist

    Versiones
    • 0.11.0
    • v0.11.1
    • v0.12.0
    • v0.13.0
    Intervalos de versiones afectados
    • ECOSYSTEM: ≥ 0.11.0, < 0.13.1

    Actualiza a 0.13.1

  • ipl/web Packagist

    Versiones
    • v0.1.0
    • v0.10.0
    • v0.10.1
    • v0.10.2
    • v0.2.0
    • v0.2.1
    • v0.3.0
    • v0.4.0
    • v0.5.0
    • v0.6.0
    • v0.7.0
    • v0.7.1
    • v0.8.0
    • v0.9.0
    • v0.9.1
    • v0.9.2
    Intervalos de versiones afectados
    • ECOSYSTEM: < 0.10.3

    Actualiza a 0.10.3

Fuentes originales

Comprueba tu servidor →