p PatchFirst

CVE-2026-42224

CVE-2026-42224 · ipl/web is vulnerable to reflected XSS by malformed search requests

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

ipl/web is a set of common web components for php projects. Prior to versions 0.13.1 and 0.10.3, the vulnerability allows an attacker to inject malicious Javascript into a victim's browser to run it in the context of Icinga Web. The victim needs to visit a specifically prepared website and may have no immediate chance to notice any wrongdoing. This issue has been patched in versions 0.13.1 and 0.10.3.

CVSS 7.6 · Élevée · EPSS 0,3% · Correctif disponible

Publication
Mise à jour

Pile logicielle: php

Produits et versions concernés

  • ipl-web

    Versions du logiciel
    • >= 0.11.0, < 0.13.1: Concernée
    • < 0.10.3: Concernée

    Aucun correctif publié

  • ipl/web Packagist

    Versions du logiciel
    • 0.11.0
    • v0.11.1
    • v0.12.0
    • v0.13.0
    Plages de versions concernées
    • ECOSYSTEM: ≥ 0.11.0, < 0.13.1

    Mettez à jour vers 0.13.1

  • ipl/web Packagist

    Versions du logiciel
    • v0.1.0
    • v0.10.0
    • v0.10.1
    • v0.10.2
    • v0.2.0
    • v0.2.1
    • v0.3.0
    • v0.4.0
    • v0.5.0
    • v0.6.0
    • v0.7.0
    • v0.7.1
    • v0.8.0
    • v0.9.0
    • v0.9.1
    • v0.9.2
    Plages de versions concernées
    • ECOSYSTEM: < 0.10.3

    Mettez à jour vers 0.10.3

Sources originales

Vérifiez votre serveur →