CVE-2026-44240
CVE-2026-44240 · basic-ftp allows a malicious FTP server to cause client-side denial of service via unbounded multiline control response buffering
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
basic-ftp is an FTP client for Node.js. Prior to 5.3.1, basic-ftp is vulnerable to client-side denial of service when parsing FTP control-channel multiline responses. A malicious or compromised FTP server can send an unterminated multiline response during the initial FTP banner phase, before authentication. The client keeps appending attacker-controlled data into FtpContext._partialResponse and repeatedly reparses the accumulated buffer without enforcing a maximum control response size. As a result, an application using basic-ftp can remain stuck in connect() while memory and CPU usage grow under attacker-controlled input. This can lead to process-level denial of service, container OOM kills, worker restarts, queue backlog, or service degradation in applications that automatically connect to FTP endpoints. This vulnerability is fixed in 5.3.1.
CVSS 7.5 · Alta · EPSS 0,5% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · node
Productos y versiones afectados
basic-ftp
- Versiones
- < 5.3.1: Afectada
Sin corrección publicada
node-proxy-agents Debian:13
- Versiones
- 0~2024040606-6
- 0~2024040606-6+deb13u1
- 0~2025070717+~cs15.2.7-1
- 0~2025070717+~cs15.3.7-1
- 0~2025070717+~cs15.3.8-1
- 0~2025070717+~cs15.3.8-2
- 0~2025070717+~cs15.3.8-3
- 0~2025070717+~cs16.2.9-1
- 0~2025070717-1
- 0~2025070717-2
- 0~2025070717-3
- 0~2025070717-4
- 0~2025070717-5
- 0~2025070717-6
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-proxy-agents Debian:14
- Versiones
- 0~2024040606-6
- 0~2025070717+~cs15.2.7-1
- 0~2025070717+~cs15.3.7-1
- 0~2025070717-1
- 0~2025070717-2
- 0~2025070717-3
- 0~2025070717-4
- 0~2025070717-5
- 0~2025070717-6
- Intervalos de versiones afectados
- ECOSYSTEM: < 0~2025070717+~cs15.3.8-1
Actualiza a 0~2025070717+~cs15.3.8-1
basic-ftp npm
- Intervalos de versiones afectados
- SEMVER: < 5.3.1
Actualiza a 5.3.1
node-proxy-agents Ubuntu:24.04:LTS
- Versiones
- 0~2023071921-5
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-proxy-agents Ubuntu:25.10
- Versiones
- 0~2024040606-5
- 0~2024040606-6
- 0~2025070717-1
- 0~2025070717-2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-proxy-agents Ubuntu:26.10
- Versiones
- 0~2025070717+~cs15.2.7-1build1
- 0~2025070717+~cs15.3.8-1
- 0~2025070717+~cs15.3.8-2
- 0~2025070717+~cs15.3.8-3
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-proxy-agents Ubuntu:26.04:LTS
- Versiones
- 0~2025070717-2
- 0~2025070717-6
- 0~2025070717+~cs15.2.7-1build1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada