p PatchFirst

CVE-2026-44240

CVE-2026-44240 · basic-ftp allows a malicious FTP server to cause client-side denial of service via unbounded multiline control response buffering

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

basic-ftp is an FTP client for Node.js. Prior to 5.3.1, basic-ftp is vulnerable to client-side denial of service when parsing FTP control-channel multiline responses. A malicious or compromised FTP server can send an unterminated multiline response during the initial FTP banner phase, before authentication. The client keeps appending attacker-controlled data into FtpContext._partialResponse and repeatedly reparses the accumulated buffer without enforcing a maximum control response size. As a result, an application using basic-ftp can remain stuck in connect() while memory and CPU usage grow under attacker-controlled input. This can lead to process-level denial of service, container OOM kills, worker restarts, queue backlog, or service degradation in applications that automatically connect to FTP endpoints. This vulnerability is fixed in 5.3.1.

CVSS 7.5 · Hoch · EPSS 0,5% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · node

Betroffene Produkte und Versionen

  • basic-ftp

    Softwareversionen
    • < 5.3.1: Betroffen

    Keine Korrektur veröffentlicht

  • node-proxy-agents Debian:13

    Softwareversionen
    • 0~2024040606-6
    • 0~2024040606-6+deb13u1
    • 0~2025070717+~cs15.2.7-1
    • 0~2025070717+~cs15.3.7-1
    • 0~2025070717+~cs15.3.8-1
    • 0~2025070717+~cs15.3.8-2
    • 0~2025070717+~cs15.3.8-3
    • 0~2025070717+~cs16.2.9-1
    • 0~2025070717-1
    • 0~2025070717-2
    • 0~2025070717-3
    • 0~2025070717-4
    • 0~2025070717-5
    • 0~2025070717-6
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-proxy-agents Debian:14

    Softwareversionen
    • 0~2024040606-6
    • 0~2025070717+~cs15.2.7-1
    • 0~2025070717+~cs15.3.7-1
    • 0~2025070717-1
    • 0~2025070717-2
    • 0~2025070717-3
    • 0~2025070717-4
    • 0~2025070717-5
    • 0~2025070717-6
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 0~2025070717+~cs15.3.8-1

    Auf 0~2025070717+~cs15.3.8-1 aktualisieren

  • basic-ftp npm

    Betroffene Versionsbereiche
    • SEMVER: < 5.3.1

    Auf 5.3.1 aktualisieren

  • node-proxy-agents Ubuntu:24.04:LTS

    Softwareversionen
    • 0~2023071921-5
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-proxy-agents Ubuntu:25.10

    Softwareversionen
    • 0~2024040606-5
    • 0~2024040606-6
    • 0~2025070717-1
    • 0~2025070717-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-proxy-agents Ubuntu:26.10

    Softwareversionen
    • 0~2025070717+~cs15.2.7-1build1
    • 0~2025070717+~cs15.3.8-1
    • 0~2025070717+~cs15.3.8-2
    • 0~2025070717+~cs15.3.8-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-proxy-agents Ubuntu:26.04:LTS

    Softwareversionen
    • 0~2025070717-2
    • 0~2025070717-6
    • 0~2025070717+~cs15.2.7-1build1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →