CVE-2026-44636
CVE-2026-44636 · libsixel: integer overflow in encoder
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
libsixel is a SIXEL encoder/decoder implementation derived from kmiya's sixel. From to 1.8.7-r1, signed integer overflow in sixel_encode_highcolor's allocation size calculation can lead to a heap buffer overflow. The public sixel_encode entry point validates only that width and height are greater than zero, with no upper bound. width and height are multiplied as plain int when computing the allocation size for paletted_pixels and normalized_pixels. Any caller that asks libsixel to encode a pixel buffer with width times height greater than INT_MAX (about 2.15 billion) will hit a wrapped allocation size; under the right wrap, the malloc succeeds with a buffer much smaller than the encoder expects, and the encoder writes past the end of the heap allocation. This vulnerability is fixed in 1.8.7-r2.
CVSS 7.4 · Alta · EPSS 0,1% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system
Productos y versiones afectados
libsixel
- Versiones
- >= 1.4.4, < 1.8.7-r2: Afectada
Sin corrección publicada
libsixel Debian:12
- Versiones
- 1.10.3-3
- 1.10.5-1
- 1:1.8.7-1
- 1:1.8.7-2
- 1:1.8.7-3
- 1:1.8.7-4
- 1:1.8.7-5
- 1:1.8.7-6
- 1:1.8.7-r2-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
libsixel Debian:13
- Versiones
- 1.10.5-1
- 1:1.8.7-1
- 1:1.8.7-2
- 1:1.8.7-3
- 1:1.8.7-4
- 1:1.8.7-5
- 1:1.8.7-6
- 1:1.8.7-r2-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
libsixel Debian:14
- Versiones
- 1.10.5-1
- 1:1.8.7-1
- 1:1.8.7-2
- 1:1.8.7-3
- 1:1.8.7-4
- 1:1.8.7-5
- 1:1.8.7-6
- Intervalos de versiones afectados
- ECOSYSTEM: < 1:1.8.7-r2-1
Actualiza a 1:1.8.7-r2-1
libsixel Ubuntu:16.04:LTS
- Versiones
- 1.4.2-1
- 1.5.2-2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
libsixel Ubuntu:18.04:LTS
- Versiones
- 1.5.2-2
- 1.7.3-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
libsixel Ubuntu:20.04:LTS
- Versiones
- 1.8.2-1
- 1.8.2-2.1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
libsixel Ubuntu:22.04:LTS
- Versiones
- 1.8.6-2
- 1.10.3-2
- 1.10.3-3
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
libsixel Ubuntu:24.04:LTS
- Versiones
- 1.10.3-3
- 1.10.3-3build1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
libsixel Ubuntu:25.10
- Versiones
- 1.10.5-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
libsixel Ubuntu:26.10
- Versiones
- 1.10.5-1build1
- 1:1.8.7-r2-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
libsixel Ubuntu:26.04:LTS
- Versiones
- 1.10.5-1
- 1.10.5-1build1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada