p PatchFirst

CVE-2026-44636

CVE-2026-44636 · libsixel: integer overflow in encoder

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

libsixel is a SIXEL encoder/decoder implementation derived from kmiya's sixel. From to 1.8.7-r1, signed integer overflow in sixel_encode_highcolor's allocation size calculation can lead to a heap buffer overflow. The public sixel_encode entry point validates only that width and height are greater than zero, with no upper bound. width and height are multiplied as plain int when computing the allocation size for paletted_pixels and normalized_pixels. Any caller that asks libsixel to encode a pixel buffer with width times height greater than INT_MAX (about 2.15 billion) will hit a wrapped allocation size; under the right wrap, the malloc succeeds with a buffer much smaller than the encoder expects, and the encoder writes past the end of the heap allocation. This vulnerability is fixed in 1.8.7-r2.

CVSS 7.4 · Hoch · EPSS 0,1% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • libsixel

    Softwareversionen
    • >= 1.4.4, < 1.8.7-r2: Betroffen

    Keine Korrektur veröffentlicht

  • libsixel Debian:12

    Softwareversionen
    • 1.10.3-3
    • 1.10.5-1
    • 1:1.8.7-1
    • 1:1.8.7-2
    • 1:1.8.7-3
    • 1:1.8.7-4
    • 1:1.8.7-5
    • 1:1.8.7-6
    • 1:1.8.7-r2-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • libsixel Debian:13

    Softwareversionen
    • 1.10.5-1
    • 1:1.8.7-1
    • 1:1.8.7-2
    • 1:1.8.7-3
    • 1:1.8.7-4
    • 1:1.8.7-5
    • 1:1.8.7-6
    • 1:1.8.7-r2-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • libsixel Debian:14

    Softwareversionen
    • 1.10.5-1
    • 1:1.8.7-1
    • 1:1.8.7-2
    • 1:1.8.7-3
    • 1:1.8.7-4
    • 1:1.8.7-5
    • 1:1.8.7-6
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1:1.8.7-r2-1

    Auf 1:1.8.7-r2-1 aktualisieren

  • libsixel Ubuntu:16.04:LTS

    Softwareversionen
    • 1.4.2-1
    • 1.5.2-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • libsixel Ubuntu:18.04:LTS

    Softwareversionen
    • 1.5.2-2
    • 1.7.3-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • libsixel Ubuntu:20.04:LTS

    Softwareversionen
    • 1.8.2-1
    • 1.8.2-2.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • libsixel Ubuntu:22.04:LTS

    Softwareversionen
    • 1.8.6-2
    • 1.10.3-2
    • 1.10.3-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • libsixel Ubuntu:24.04:LTS

    Softwareversionen
    • 1.10.3-3
    • 1.10.3-3build1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • libsixel Ubuntu:25.10

    Softwareversionen
    • 1.10.5-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • libsixel Ubuntu:26.10

    Softwareversionen
    • 1.10.5-1build1
    • 1:1.8.7-r2-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • libsixel Ubuntu:26.04:LTS

    Softwareversionen
    • 1.10.5-1
    • 1.10.5-1build1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →