CVE-2026-44728
CVE-2026-44728 · Improper Control of Generation of Code when compiling specifically crafted malicious code with @babel/plugin-transform-modules-systemjs
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Babel is a compiler for writing next generation JavaScript. From 7.12.0 to before 7.29.4 and 8.0.0-alpha.13, using Babel to compile code that was specifically crafted by an attacker can cause Babel to generate output code that executes arbitrary code. This vulnerability is fixed in 7.29.4 and 8.0.0-alpha.13.
CVSS 8.2 · Alta · EPSS 0,1% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · node
Productos y versiones afectados
babel
- Versiones
- >= 7.12.0, < 7.29.4: Afectada
- >= 8.0.0-alpha.0, < 8.0.0-alpha.13: Afectada
Sin corrección publicada
plugin-transform-modules-systemjs
- Versiones
- >= 7.12.0, < 7.29.4: Afectada
- >= 8.0.0-alpha.0, < 8.0.0-alpha.13: Afectada
Sin corrección publicada
node-babel7 Debian:12
- Versiones
- 7.20.15+ds1+~cs214.269.168-10
- 7.20.15+ds1+~cs214.269.168-11
- 7.20.15+ds1+~cs214.269.168-12
- 7.20.15+ds1+~cs214.269.168-13
- 7.20.15+ds1+~cs214.269.168-14
- 7.20.15+ds1+~cs214.269.168-15
- 7.20.15+ds1+~cs214.269.168-16
- 7.20.15+ds1+~cs214.269.168-17
- 7.20.15+ds1+~cs214.269.168-18
- 7.20.15+ds1+~cs214.269.168-3
- 7.20.15+ds1+~cs214.269.168-3+deb12u1
- 7.20.15+ds1+~cs214.269.168-3+deb12u2
- 7.20.15+ds1+~cs214.269.168-4
- 7.20.15+ds1+~cs214.269.168-5
- 7.20.15+ds1+~cs214.269.168-6
- 7.20.15+ds1+~cs214.269.168-7
- 7.20.15+ds1+~cs214.269.168-8
- 7.20.15+ds1+~cs214.269.168-9
- 8.0.4+ds1+~cs177.303.116-1
- 8.0.4+ds1+~cs177.303.116-2
- 8.0.4+ds1+~cs177.303.116-3
- 8.0.6+ds1+~cs177.303.116-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-babel7 Debian:13
- Versiones
- 7.20.15+ds1+~cs214.269.168-10
- 7.20.15+ds1+~cs214.269.168-11
- 7.20.15+ds1+~cs214.269.168-12
- 7.20.15+ds1+~cs214.269.168-13
- 7.20.15+ds1+~cs214.269.168-14
- 7.20.15+ds1+~cs214.269.168-15
- 7.20.15+ds1+~cs214.269.168-16
- 7.20.15+ds1+~cs214.269.168-17
- 7.20.15+ds1+~cs214.269.168-18
- 7.20.15+ds1+~cs214.269.168-8
- 7.20.15+ds1+~cs214.269.168-9
- 8.0.4+ds1+~cs177.303.116-1
- 8.0.4+ds1+~cs177.303.116-2
- 8.0.4+ds1+~cs177.303.116-3
- 8.0.6+ds1+~cs177.303.116-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-babel7 Debian:14
- Versiones
- 7.20.15+ds1+~cs214.269.168-10
- 7.20.15+ds1+~cs214.269.168-11
- 7.20.15+ds1+~cs214.269.168-12
- 7.20.15+ds1+~cs214.269.168-13
- 7.20.15+ds1+~cs214.269.168-14
- 7.20.15+ds1+~cs214.269.168-15
- 7.20.15+ds1+~cs214.269.168-16
- 7.20.15+ds1+~cs214.269.168-17
- 7.20.15+ds1+~cs214.269.168-18
- 7.20.15+ds1+~cs214.269.168-8
- 7.20.15+ds1+~cs214.269.168-9
- 8.0.4+ds1+~cs177.303.116-1
- Intervalos de versiones afectados
- ECOSYSTEM: < 8.0.4+ds1+~cs177.303.116-2
Actualiza a 8.0.4+ds1+~cs177.303.116-2
@babel/plugin-transform-modules-systemjs npm
- Intervalos de versiones afectados
- SEMVER: ≥ 7.12.0, < 7.29.4
Actualiza a 7.29.4
@babel/plugin-transform-modules-systemjs npm
- Intervalos de versiones afectados
- SEMVER: ≥ 8.0.0-alpha.0, < 8.0.0-alpha.13
Actualiza a 8.0.0-alpha.13
node-babel7 Ubuntu:22.04:LTS
- Versiones
- 7.12.12+~cs150.141.84-6
- 7.12.12+~cs150.141.84-7
- 7.12.12+~cs150.141.84-8
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-babel7 Ubuntu:24.04:LTS
- Versiones
- 7.20.15+ds1+~cs214.269.168-4
- 7.20.15+ds1+~cs214.269.168-5
- 7.20.15+ds1+~cs214.269.168-6
- 7.20.15+ds1+~cs214.269.168-6build1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-babel7 Ubuntu:25.10
- Versiones
- 7.20.15+ds1+~cs214.269.168-8
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-babel7 Ubuntu:26.10
- Versiones
- 7.20.15+ds1+~cs214.269.168-16
- 7.20.15+ds1+~cs214.269.168-17build1
- 7.20.15+ds1+~cs214.269.168-17build2
- 7.20.15+ds1+~cs214.269.168-18
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-babel7 Ubuntu:26.04:LTS
- Versiones
- 7.20.15+ds1+~cs214.269.168-8
- 7.20.15+ds1+~cs214.269.168-9
- 7.20.15+ds1+~cs214.269.168-11build1
- 7.20.15+ds1+~cs214.269.168-14
- 7.20.15+ds1+~cs214.269.168-16
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada