CVE-2026-45293
CVE-2026-45293 · WordPress Coding Standards (WordPressCS) contains an arbitrary code execution vulnerability
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
WordPress Coding Standards is a set of PHP_CodeSniffer rules (sniffs) that enforce WordPress coding conventions. From 0.14.1 until 3.4.1, the WordPress.WP.EnqueuedResourceParameters sniff (active in the WordPress and WordPress-Extra rulesets) reconstructed the $ver argument passed to functions such as wp_enqueue_script() and ran it through eval() inside its is_falsy() method, so a maliciously crafted argument such as 'system'('id') would execute during a scan; as a result, running PHPCS with WordPressCS over untrusted PHP (for example a CI pipeline that lints pull requests, or a developer reviewing third-party code) could lead to arbitrary command execution on the scanning host. The WordPress-Core and WordPress-Docs rulesets are not affected. This issue is fixed in version 3.4.1.
CVSS 8.6 · Alta · EPSS 0,2% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: php
Productos y versiones afectados
wordpress-coding-standards
- Versiones
- >= 0.14.1, < 3.4.1: Afectada
Sin corrección publicada
wp-coding-standards/wpcs Packagist
- Versiones
- 0.14.1
- 1.0.0
- 1.1.0
- 1.2.0
- 1.2.1
- 2.0.0
- 2.0.0-RC1
- 2.1.0
- 2.1.1
- 2.2.0
- 2.2.1
- 2.3.0
- 3.0.0
- 3.0.1
- 3.1.0
- 3.2.0
- 3.3.0
- 3.4.0
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 0.14.1, < 3.4.1
Actualiza a 3.4.1
Fuentes originales
- https://github.com/WordPress/WordPress-Coding-Standards/security/advisories/GHSA-3pwp-g2mj-5p3v
- https://github.com/WordPress/WordPress-Coding-Standards/pull/2771
- https://github.com/WordPress/WordPress-Coding-Standards/commit/a29048d0bbef5cf25d42349c74e4072d3cbc8325
- https://github.com/WordPress/WordPress-Coding-Standards/releases/tag/3.4.1
- https://nvd.nist.gov/vuln/detail/CVE-2026-45293