p PatchFirst

CVE-2026-45293

CVE-2026-45293 · WordPress Coding Standards (WordPressCS) contains an arbitrary code execution vulnerability

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

WordPress Coding Standards is a set of PHP_CodeSniffer rules (sniffs) that enforce WordPress coding conventions. From 0.14.1 until 3.4.1, the WordPress.WP.EnqueuedResourceParameters sniff (active in the WordPress and WordPress-Extra rulesets) reconstructed the $ver argument passed to functions such as wp_enqueue_script() and ran it through eval() inside its is_falsy() method, so a maliciously crafted argument such as 'system'('id') would execute during a scan; as a result, running PHPCS with WordPressCS over untrusted PHP (for example a CI pipeline that lints pull requests, or a developer reviewing third-party code) could lead to arbitrary command execution on the scanning host. The WordPress-Core and WordPress-Docs rulesets are not affected. This issue is fixed in version 3.4.1.

CVSS 8.6 · Hoch · EPSS 0,2% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: php

Betroffene Produkte und Versionen

  • wordpress-coding-standards

    Softwareversionen
    • >= 0.14.1, < 3.4.1: Betroffen

    Keine Korrektur veröffentlicht

  • wp-coding-standards/wpcs Packagist

    Softwareversionen
    • 0.14.1
    • 1.0.0
    • 1.1.0
    • 1.2.0
    • 1.2.1
    • 2.0.0
    • 2.0.0-RC1
    • 2.1.0
    • 2.1.1
    • 2.2.0
    • 2.2.1
    • 2.3.0
    • 3.0.0
    • 3.0.1
    • 3.1.0
    • 3.2.0
    • 3.3.0
    • 3.4.0
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 0.14.1, < 3.4.1

    Auf 3.4.1 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →