p PatchFirst

CVE-2026-45736

CVE-2026-45736 · ws: Uninitialized memory disclosure

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Esta página muestra una selección de datos de las fuentes. Consulte los avisos enlazados para ver la descripción completa y las versiones afectadas.

ws is an open source WebSocket client and server for Node.js. Prior to 8.20.1, the websocket.close() implementation is vulnerable to uninitialized memory disclosure when a TypedArray is passed as the reason argument. This vulnerability is fixed in 8.20.1.

CVSS 4.4 · Media · EPSS 0,7% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system · node

Productos y versiones afectados

  • ws

    Versiones
    • >= 8.0.0, < 8.20.1: Afectada

    Sin corrección publicada

  • node-ws Debian:12

    Versiones
    • 8.11.0+~cs13.7.3-1
    • 8.11.0+~cs13.7.3-2
    • 8.18.0+~cs13.7.11-1
    • 8.18.0+~cs14.5.15-1
    • 8.18.1+~cs14.18.2-1
    • 8.19.0+~cs14.19.1-1
    • 8.20.1+~cs14.19.1-1
    • 8.21.0+~cs14.19.1-1
    • 8.21.1+~cs14.19.1-1
    • 8.21.3+~cs14.19.1-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-ws Debian:13

    Versiones
    • 8.18.1+~cs14.18.2-1
    • 8.19.0+~cs14.19.1-1
    • 8.20.1+~cs14.19.1-1
    • 8.21.0+~cs14.19.1-1
    • 8.21.1+~cs14.19.1-1
    • 8.21.3+~cs14.19.1-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-ws Debian:14

    Versiones
    • 8.18.1+~cs14.18.2-1
    • 8.19.0+~cs14.19.1-1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 8.20.1+~cs14.19.1-1

    Actualiza a 8.20.1+~cs14.19.1-1

  • ws npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 8.0.0, < 8.20.1

    Actualiza a 8.20.1

  • node-ws Ubuntu:16.04:LTS

    Versiones
    • 0.7.2+ds1.349b7460-1
    • 1.0.1+ds1.e6ddaae4-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-ws Ubuntu:18.04:LTS

    Versiones
    • 1.1.0+ds1.e6ddaae4-3build1
    • 1.1.0+ds1.e6ddaae4-3ubuntu1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-ws Ubuntu:20.04:LTS

    Versiones
    • 1.1.0+ds1.e6ddaae4-5
    • 7.2.1-2
    • 7.2.1-3
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-ws Ubuntu:22.04:LTS

    Versiones
    • 7.4.2+~cs18.0.8-2
    • 7.5.5+~cs13.0.13-1
    • 8.5.0+~cs13.3.3-2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-ws Ubuntu:24.04:LTS

    Versiones
    • 8.11.0+~cs13.7.3-1
    • 8.11.0+~cs13.7.3-2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-ws Ubuntu:25.10

    Versiones
    • 8.18.0+~cs14.5.15-1
    • 8.18.1+~cs14.18.2-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-ws Ubuntu:26.10

    Versiones
    • 8.19.0+~cs14.19.1-1
    • 8.20.1+~cs14.19.1-1
    • 8.21.3+~cs14.19.1-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-ws Ubuntu:26.04:LTS

    Versiones
    • 8.18.1+~cs14.18.2-1
    • 8.19.0+~cs14.19.1-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

Fuentes originales

Comprueba tu servidor →