p PatchFirst

CVE-2026-45736

CVE-2026-45736 · ws: Uninitialized memory disclosure

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Diese Seite zeigt ausgewählte Angaben aus den Quellen. Die vollständige Beschreibung und betroffene Versionen finden Sie in den verlinkten Sicherheitshinweisen.

ws is an open source WebSocket client and server for Node.js. Prior to 8.20.1, the websocket.close() implementation is vulnerable to uninitialized memory disclosure when a TypedArray is passed as the reason argument. This vulnerability is fixed in 8.20.1.

CVSS 4.4 · Mittel · EPSS 0,7% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · node

Betroffene Produkte und Versionen

  • ws

    Softwareversionen
    • >= 8.0.0, < 8.20.1: Betroffen

    Keine Korrektur veröffentlicht

  • node-ws Debian:12

    Softwareversionen
    • 8.11.0+~cs13.7.3-1
    • 8.11.0+~cs13.7.3-2
    • 8.18.0+~cs13.7.11-1
    • 8.18.0+~cs14.5.15-1
    • 8.18.1+~cs14.18.2-1
    • 8.19.0+~cs14.19.1-1
    • 8.20.1+~cs14.19.1-1
    • 8.21.0+~cs14.19.1-1
    • 8.21.1+~cs14.19.1-1
    • 8.21.3+~cs14.19.1-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-ws Debian:13

    Softwareversionen
    • 8.18.1+~cs14.18.2-1
    • 8.19.0+~cs14.19.1-1
    • 8.20.1+~cs14.19.1-1
    • 8.21.0+~cs14.19.1-1
    • 8.21.1+~cs14.19.1-1
    • 8.21.3+~cs14.19.1-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-ws Debian:14

    Softwareversionen
    • 8.18.1+~cs14.18.2-1
    • 8.19.0+~cs14.19.1-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 8.20.1+~cs14.19.1-1

    Auf 8.20.1+~cs14.19.1-1 aktualisieren

  • ws npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 8.0.0, < 8.20.1

    Auf 8.20.1 aktualisieren

  • node-ws Ubuntu:16.04:LTS

    Softwareversionen
    • 0.7.2+ds1.349b7460-1
    • 1.0.1+ds1.e6ddaae4-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-ws Ubuntu:18.04:LTS

    Softwareversionen
    • 1.1.0+ds1.e6ddaae4-3build1
    • 1.1.0+ds1.e6ddaae4-3ubuntu1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-ws Ubuntu:20.04:LTS

    Softwareversionen
    • 1.1.0+ds1.e6ddaae4-5
    • 7.2.1-2
    • 7.2.1-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-ws Ubuntu:22.04:LTS

    Softwareversionen
    • 7.4.2+~cs18.0.8-2
    • 7.5.5+~cs13.0.13-1
    • 8.5.0+~cs13.3.3-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-ws Ubuntu:24.04:LTS

    Softwareversionen
    • 8.11.0+~cs13.7.3-1
    • 8.11.0+~cs13.7.3-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-ws Ubuntu:25.10

    Softwareversionen
    • 8.18.0+~cs14.5.15-1
    • 8.18.1+~cs14.18.2-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-ws Ubuntu:26.10

    Softwareversionen
    • 8.19.0+~cs14.19.1-1
    • 8.20.1+~cs14.19.1-1
    • 8.21.3+~cs14.19.1-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-ws Ubuntu:26.04:LTS

    Softwareversionen
    • 8.18.1+~cs14.18.2-1
    • 8.19.0+~cs14.19.1-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →