CVE-2026-49477
CVE-2026-49477 · Soup Sieve: Regular Expression Denial of Service (ReDoS) in soupsieve Selector Parser
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Soup Sieve is a CSS selector library designed to be used with Beautiful Soup 4. Prior to 2.8.4, the CSS selector parser in soupsieve contains a regular expression vulnerable to catastrophic backtracking when processing an attribute selector with an unterminated quoted value in soupsieve/css_parser.py, allowing an attacker who can supply untrusted CSS selector strings to soupsieve.compile() or Beautiful Soup .select() / .select_one() to cause CPU exhaustion and denial of service. This issue is fixed in version 2.8.4.
CVSS 7.5 · Alta · EPSS 0,6% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · python
Productos y versiones afectados
soupsieve
- Versiones
- < 2.8.4: Afectada
Sin corrección publicada
soupsieve Debian:12
- Versiones
- 2.3.2-1
- 2.4-1
- 2.4.1-1
- 2.4.1-2
- 2.5-1
- 2.6-1
- 2.7-1
- 2.7-2
- 2.8.1-1
- 2.8.3-1
- 2.8.4-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
soupsieve Debian:13
- Versiones
- 2.7-1
- 2.7-2
- 2.8.1-1
- 2.8.3-1
- 2.8.4-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
soupsieve Debian:14
- Versiones
- 2.7-1
- 2.7-2
- 2.8.1-1
- 2.8.3-1
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.8.4-1
Actualiza a 2.8.4-1
soupsieve PyPI
- Versiones
- 0.4
- 0.5
- 0.5.1
- 0.5.2
- 0.5.3
- 0.6
- 1.0
- 1.0.1
- 1.0.2
- 1.0b1
- 1.0b2
- 1.1
- 1.2
- 1.2.1
- 1.3
- 1.3.1
- 1.4
- 1.5
- 1.6
- 1.6.1
- 1.6.2
- 1.7
- 1.7.1
- 1.7.2
- 1.7.3
- 1.8
- 1.9
- 1.9.1
- 1.9.2
- 1.9.3
- 1.9.4
- 1.9.5
- 1.9.6
- 2.0
- 2.0.1
- 2.1
- 2.2
- 2.2.1
- 2.3
- 2.3.1
- 2.3.2
- 2.3.2.post1
- 2.4
- 2.4.1
- 2.5
- 2.6
- 2.7
- 2.8
- 2.8.1
- 2.8.2
- 2.8.3
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.8.4
Actualiza a 2.8.4
soupsieve Ubuntu:20.04:LTS
- Versiones
- 1.9.2+dfsg-2ubuntu1
- 1.9.4+dfsg-1
- 1.9.5+dfsg-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
soupsieve Ubuntu:22.04:LTS
- Versiones
- 2.2.1-2
- 2.3-1
- 2.3.1-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
soupsieve Ubuntu:24.04:LTS
- Versiones
- 2.4.1-2
- 2.5-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
soupsieve Ubuntu:26.10
- Versiones
- 2.8.3-1
- 2.8.4-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
soupsieve Ubuntu:26.04:LTS
- Versiones
- 2.7-2
- 2.8.1-1
- 2.8.3-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada