p PatchFirst

CVE-2026-49477

CVE-2026-49477 · Soup Sieve: Regular Expression Denial of Service (ReDoS) in soupsieve Selector Parser

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Soup Sieve is a CSS selector library designed to be used with Beautiful Soup 4. Prior to 2.8.4, the CSS selector parser in soupsieve contains a regular expression vulnerable to catastrophic backtracking when processing an attribute selector with an unterminated quoted value in soupsieve/css_parser.py, allowing an attacker who can supply untrusted CSS selector strings to soupsieve.compile() or Beautiful Soup .select() / .select_one() to cause CPU exhaustion and denial of service. This issue is fixed in version 2.8.4.

CVSS 7.5 · Hoch · EPSS 0,6% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · python

Betroffene Produkte und Versionen

  • soupsieve

    Softwareversionen
    • < 2.8.4: Betroffen

    Keine Korrektur veröffentlicht

  • soupsieve Debian:12

    Softwareversionen
    • 2.3.2-1
    • 2.4-1
    • 2.4.1-1
    • 2.4.1-2
    • 2.5-1
    • 2.6-1
    • 2.7-1
    • 2.7-2
    • 2.8.1-1
    • 2.8.3-1
    • 2.8.4-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • soupsieve Debian:13

    Softwareversionen
    • 2.7-1
    • 2.7-2
    • 2.8.1-1
    • 2.8.3-1
    • 2.8.4-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • soupsieve Debian:14

    Softwareversionen
    • 2.7-1
    • 2.7-2
    • 2.8.1-1
    • 2.8.3-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.8.4-1

    Auf 2.8.4-1 aktualisieren

  • soupsieve PyPI

    Softwareversionen
    • 0.4
    • 0.5
    • 0.5.1
    • 0.5.2
    • 0.5.3
    • 0.6
    • 1.0
    • 1.0.1
    • 1.0.2
    • 1.0b1
    • 1.0b2
    • 1.1
    • 1.2
    • 1.2.1
    • 1.3
    • 1.3.1
    • 1.4
    • 1.5
    • 1.6
    • 1.6.1
    • 1.6.2
    • 1.7
    • 1.7.1
    • 1.7.2
    • 1.7.3
    • 1.8
    • 1.9
    • 1.9.1
    • 1.9.2
    • 1.9.3
    • 1.9.4
    • 1.9.5
    • 1.9.6
    • 2.0
    • 2.0.1
    • 2.1
    • 2.2
    • 2.2.1
    • 2.3
    • 2.3.1
    • 2.3.2
    • 2.3.2.post1
    • 2.4
    • 2.4.1
    • 2.5
    • 2.6
    • 2.7
    • 2.8
    • 2.8.1
    • 2.8.2
    • 2.8.3
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.8.4

    Auf 2.8.4 aktualisieren

  • soupsieve Ubuntu:20.04:LTS

    Softwareversionen
    • 1.9.2+dfsg-2ubuntu1
    • 1.9.4+dfsg-1
    • 1.9.5+dfsg-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • soupsieve Ubuntu:22.04:LTS

    Softwareversionen
    • 2.2.1-2
    • 2.3-1
    • 2.3.1-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • soupsieve Ubuntu:24.04:LTS

    Softwareversionen
    • 2.4.1-2
    • 2.5-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • soupsieve Ubuntu:26.10

    Softwareversionen
    • 2.8.3-1
    • 2.8.4-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • soupsieve Ubuntu:26.04:LTS

    Softwareversionen
    • 2.7-2
    • 2.8.1-1
    • 2.8.3-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →