p PatchFirst

CVE-2026-53550

CVE-2026-53550 · js-yaml: Quadratic-complexity DoS in merge key handling via repeated aliases

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

js-yaml is a JavaScript YAML parser and dumper. Prior to 4.2.0 and 3.15.0, a crafted YAML document can trigger algorithmic CPU exhaustion in js-yaml merge-key processing (<<) by repeating the same alias many times in a merge sequence. This causes quadratic parse-time behavior relative to input size and can block a Node.js worker/event loop for seconds with a relatively small payload (tens of KB), resulting in denial of service. The issue is in merge handling inside lib/loader.js. This vulnerability is fixed in 4.2.0 and 3.15.0.

CVSS 5.3 · Media · EPSS 0,4% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system · node

Productos y versiones afectados

  • js-yaml

    Versiones
    • >= 4.0.0, < 4.2.0: Afectada
    • < 3.15.0: Afectada

    Sin corrección publicada

  • node-js-yaml Debian:12

    Versiones
    • 4.1.0+dfsg+~4.0.5-7
    • 4.1.1+dfsg+~4.0.9-1
    • 4.2.0+~4.0.9-1
    • 4.2.0+~4.0.9-2
    • 4.3.2+~4.0.9-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-js-yaml Debian:13

    Versiones
    • 4.1.0+dfsg+~4.0.5-7
    • 4.1.1+dfsg+~4.0.9-1
    • 4.2.0+~4.0.9-1
    • 4.2.0+~4.0.9-2
    • 4.3.2+~4.0.9-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-js-yaml Debian:14

    Versiones
    • 4.1.0+dfsg+~4.0.5-7
    • 4.1.1+dfsg+~4.0.9-1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 4.2.0+~4.0.9-1

    Actualiza a 4.2.0+~4.0.9-1

  • js-yaml npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 4.0.0, < 4.2.0

    Actualiza a 4.2.0

  • js-yaml npm

    Intervalos de versiones afectados
    • SEMVER: < 3.15.0

    Actualiza a 3.15.0

  • node-js-yaml Ubuntu:18.04:LTS

    Versiones
    • 3.9.1+dfsg-1
    • 3.10.0+dfsg-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-js-yaml Ubuntu:20.04:LTS

    Versiones
    • 3.13.1+dfsg-2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-js-yaml Ubuntu:22.04:LTS

    Versiones
    • 3.14.1+dfsg+~3.12.6-2
    • 4.1.0+dfsg+~4.0.5-4ubuntu1
    • 4.1.0+dfsg+~4.0.5-5
    • 4.1.0+dfsg+~4.0.5-6
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-js-yaml Ubuntu:24.04:LTS

    Versiones
    • 4.1.0+dfsg+~4.0.5-7
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-js-yaml Ubuntu:25.10

    Versiones
    • 4.1.0+dfsg+~4.0.5-7
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-js-yaml Ubuntu:26.10

    Versiones
    • 4.1.1+dfsg+~4.0.9-1
    • 4.2.0+~4.0.9-1
    • 4.2.0+~4.0.9-2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-js-yaml Ubuntu:26.04:LTS

    Versiones
    • 4.1.0+dfsg+~4.0.5-7
    • 4.1.1+dfsg+~4.0.9-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

Fuentes originales

Comprueba tu servidor →