CVE-2026-53550
CVE-2026-53550 · js-yaml: Quadratic-complexity DoS in merge key handling via repeated aliases
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
js-yaml is a JavaScript YAML parser and dumper. Prior to 4.2.0 and 3.15.0, a crafted YAML document can trigger algorithmic CPU exhaustion in js-yaml merge-key processing (<<) by repeating the same alias many times in a merge sequence. This causes quadratic parse-time behavior relative to input size and can block a Node.js worker/event loop for seconds with a relatively small payload (tens of KB), resulting in denial of service. The issue is in merge handling inside lib/loader.js. This vulnerability is fixed in 4.2.0 and 3.15.0.
CVSS 5.3 · Mittel · EPSS 0,4% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · node
Betroffene Produkte und Versionen
js-yaml
- Softwareversionen
- >= 4.0.0, < 4.2.0: Betroffen
- < 3.15.0: Betroffen
Keine Korrektur veröffentlicht
node-js-yaml Debian:12
- Softwareversionen
- 4.1.0+dfsg+~4.0.5-7
- 4.1.1+dfsg+~4.0.9-1
- 4.2.0+~4.0.9-1
- 4.2.0+~4.0.9-2
- 4.3.2+~4.0.9-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-js-yaml Debian:13
- Softwareversionen
- 4.1.0+dfsg+~4.0.5-7
- 4.1.1+dfsg+~4.0.9-1
- 4.2.0+~4.0.9-1
- 4.2.0+~4.0.9-2
- 4.3.2+~4.0.9-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-js-yaml Debian:14
- Softwareversionen
- 4.1.0+dfsg+~4.0.5-7
- 4.1.1+dfsg+~4.0.9-1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 4.2.0+~4.0.9-1
Auf 4.2.0+~4.0.9-1 aktualisieren
js-yaml npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 4.0.0, < 4.2.0
Auf 4.2.0 aktualisieren
js-yaml npm
- Betroffene Versionsbereiche
- SEMVER: < 3.15.0
Auf 3.15.0 aktualisieren
node-js-yaml Ubuntu:18.04:LTS
- Softwareversionen
- 3.9.1+dfsg-1
- 3.10.0+dfsg-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-js-yaml Ubuntu:20.04:LTS
- Softwareversionen
- 3.13.1+dfsg-2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-js-yaml Ubuntu:22.04:LTS
- Softwareversionen
- 3.14.1+dfsg+~3.12.6-2
- 4.1.0+dfsg+~4.0.5-4ubuntu1
- 4.1.0+dfsg+~4.0.5-5
- 4.1.0+dfsg+~4.0.5-6
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-js-yaml Ubuntu:24.04:LTS
- Softwareversionen
- 4.1.0+dfsg+~4.0.5-7
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-js-yaml Ubuntu:25.10
- Softwareversionen
- 4.1.0+dfsg+~4.0.5-7
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-js-yaml Ubuntu:26.10
- Softwareversionen
- 4.1.1+dfsg+~4.0.9-1
- 4.2.0+~4.0.9-1
- 4.2.0+~4.0.9-2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-js-yaml Ubuntu:26.04:LTS
- Softwareversionen
- 4.1.0+dfsg+~4.0.5-7
- 4.1.1+dfsg+~4.0.9-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht