p PatchFirst

CVE-2026-53587

CVE-2026-53587 · libgit2 - Unauthenticated network-reachable heap out-of-bounds read in transports/smart_pkt.c:set_data

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

libgit2 is a portable C implementation of the Git core methods provided as a linkable library with a solid API, allowing to build Git functionality into your application. Prior to 1.8.6 and 1.9.5, libgit2 performs a fixed-size strncmp in set_data in src/libgit2/transports/smart_pkt.c without first verifying that the smart-protocol pkt-line capability buffer contains 14 bytes. A malicious Git server can make bytes after the pkt-line complete object-format=, causing format_str to advance beyond the pkt-line and the following memchr length calculation to underflow. The resulting heap out-of-bounds walk can crash a client during the first refs-advertisement packet over HTTP, HTTPS, SSH, or the Git protocol. This issue is fixed in versions 1.8.6 and 1.9.5.

CVSS 7.5 · Alta · EPSS 0,5% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system

Productos y versiones afectados

  • libgit2

    Versiones
    • < 1.8.6: Afectada
    • >= 1.9.0, < 1.9.5: Afectada

    Sin corrección publicada

  • libgit2 Debian:13

    Versiones
    • 1.9.0+ds-2
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.9.0+ds-2+deb13u1

    Actualiza a 1.9.0+ds-2+deb13u1

  • libgit2 Debian:14

    Versiones
    • 1.9.0+ds-2
    • 1.9.1+ds-1
    • 1.9.2+ds-1
    • 1.9.2+ds-2
    • 1.9.2+ds-3
    • 1.9.2+ds-4
    • 1.9.2+ds-5
    • 1.9.2+ds-6
    • 1.9.2+ds-7
    • 1.9.2+ds-8
    • 1.9.2+ds-9
    • 1.9.3+ds-1
    • 1.9.4+ds-1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.9.6+ds-1

    Actualiza a 1.9.6+ds-1

  • libgit2 Ubuntu:24.04:LTS

    Versiones
    • 1.5.1+ds-1ubuntu1
    • 1.7.1+ds-2ubuntu1
    • 1.7.2+ds-1ubuntu1
    • 1.7.2+ds-1ubuntu2
    • 1.7.2+ds-1ubuntu3
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.7.2+ds-1ubuntu3.1

    Actualiza a 1.7.2+ds-1ubuntu3.1

  • libgit2 Ubuntu:26.04:LTS

    Versiones
    • 1.9.0+ds-2ubuntu2
    • 1.9.1+ds-1ubuntu1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.9.1+ds-1ubuntu1.1

    Actualiza a 1.9.1+ds-1ubuntu1.1

Fuentes originales

Comprueba tu servidor →