CVE-2026-53587
CVE-2026-53587 · libgit2 - Unauthenticated network-reachable heap out-of-bounds read in transports/smart_pkt.c:set_data
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
libgit2 is a portable C implementation of the Git core methods provided as a linkable library with a solid API, allowing to build Git functionality into your application. Prior to 1.8.6 and 1.9.5, libgit2 performs a fixed-size strncmp in set_data in src/libgit2/transports/smart_pkt.c without first verifying that the smart-protocol pkt-line capability buffer contains 14 bytes. A malicious Git server can make bytes after the pkt-line complete object-format=, causing format_str to advance beyond the pkt-line and the following memchr length calculation to underflow. The resulting heap out-of-bounds walk can crash a client during the first refs-advertisement packet over HTTP, HTTPS, SSH, or the Git protocol. This issue is fixed in versions 1.8.6 and 1.9.5.
CVSS 7.5 · Hoch · EPSS 0,5% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system
Betroffene Produkte und Versionen
libgit2
- Softwareversionen
- < 1.8.6: Betroffen
- >= 1.9.0, < 1.9.5: Betroffen
Keine Korrektur veröffentlicht
libgit2 Debian:13
- Softwareversionen
- 1.9.0+ds-2
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.9.0+ds-2+deb13u1
Auf 1.9.0+ds-2+deb13u1 aktualisieren
libgit2 Debian:14
- Softwareversionen
- 1.9.0+ds-2
- 1.9.1+ds-1
- 1.9.2+ds-1
- 1.9.2+ds-2
- 1.9.2+ds-3
- 1.9.2+ds-4
- 1.9.2+ds-5
- 1.9.2+ds-6
- 1.9.2+ds-7
- 1.9.2+ds-8
- 1.9.2+ds-9
- 1.9.3+ds-1
- 1.9.4+ds-1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.9.6+ds-1
Auf 1.9.6+ds-1 aktualisieren
libgit2 Ubuntu:24.04:LTS
- Softwareversionen
- 1.5.1+ds-1ubuntu1
- 1.7.1+ds-2ubuntu1
- 1.7.2+ds-1ubuntu1
- 1.7.2+ds-1ubuntu2
- 1.7.2+ds-1ubuntu3
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.7.2+ds-1ubuntu3.1
Auf 1.7.2+ds-1ubuntu3.1 aktualisieren
libgit2 Ubuntu:26.04:LTS
- Softwareversionen
- 1.9.0+ds-2ubuntu2
- 1.9.1+ds-1ubuntu1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.9.1+ds-1ubuntu1.1
Auf 1.9.1+ds-1ubuntu1.1 aktualisieren
Originalquellen
- https://github.com/libgit2/libgit2/security/advisories/GHSA-pm24-4jhq-3xvm
- https://github.com/libgit2/libgit2/commit/2c0ce8c0132ac38ab0db28239462a671e2e5440e
- https://github.com/libgit2/libgit2/commit/affda60c10fcef16723451c0d7dc71b71dc20ad3
- https://github.com/libgit2/libgit2/commit/d7a9fb87f504434e9f45228678953c4fa56e7640
- https://github.com/libgit2/libgit2/releases/tag/v1.8.6
- https://github.com/libgit2/libgit2/releases/tag/v1.9.5
- https://nvd.nist.gov/vuln/detail/CVE-2026-53587