p PatchFirst

CVE-2026-53614

CVE-2026-53614 · util-linux LIBMOUNT_FORCE_MOUNT2 allows nosuid and noexec bypass

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

util-linux is a random collection of Linux utilities. In util-linux 2.39.1 through 2.41.4 and 2.42 through 2.42.1, the SUID `mount` utility reads the attacker-controlled `LIBMOUNT_FORCE_MOUNT2` environment variable with `getenv()`, allowing a local low-privileged user to force the non-atomic legacy bind-mount path. With an `/etc/fstab` bind mount authorized by `user` or `users` and protected by `nosuid`, `noexec`, or `nodev`, an attacker can race the window between the initial bind mount and the remount that applies those security flags and execute a SUID program from the temporarily unprotected mount, potentially gaining root privileges. This issue is fixed in 2.41.5 and 2.42.2.

CVSS 7.0 · Alta · EPSS 0,1% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system

Productos y versiones afectados

  • util-linux

    Versiones
    • >= 2.39.1, < 2.41.5: Afectada
    • >= 2.42, < 2.42.2: Afectada

    Sin corrección publicada

  • util-linux Debian:13

    Versiones
    • 2.41-5
    • 2.41.1-1
    • 2.41.1-2
    • 2.41.1-3
    • 2.41.1-4
    • 2.41.2-1
    • 2.41.2-2
    • 2.41.2-3
    • 2.41.2-4
    • 2.41.3-1
    • 2.41.3-2
    • 2.41.3-3
    • 2.41.3-4
    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.41.5-0+deb13u1

    Actualiza a 2.41.5-0+deb13u1

  • util-linux Debian:14

    Versiones
    • 2.41-5
    • 2.41.1-1
    • 2.41.1-2
    • 2.41.1-3
    • 2.41.1-4
    • 2.41.2-1
    • 2.41.2-2
    • 2.41.2-3
    • 2.41.2-4
    • 2.41.3-1
    • 2.41.3-2
    • 2.41.3-3
    • 2.41.3-4
    • 2.42-1
    • 2.42-2
    • 2.42-3
    • 2.42-4
    • 2.42-5
    • 2.42-6
    • 2.42.1-1
    • 2.42.1-2
    • 2.42.1-3
    • 2.42.1-4
    • 2.42.1-5
    • 2.42.1-6
    • 2.42~rc1-1
    • 2.42~rc1-2
    • 2.42~rc1-3
    • 2.42~rc2-1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.42.2-1

    Actualiza a 2.42.2-1

  • util-linux Ubuntu:24.04:LTS

    Versiones
    • 2.39.1-4ubuntu2
    • 2.39.2-6ubuntu1
    • 2.39.3-6ubuntu2
    • 2.39.3-9ubuntu2
    • 2.39.3-9ubuntu4
    • 2.39.3-9ubuntu6
    • 2.39.3-9ubuntu6.1
    • 2.39.3-9ubuntu6.2
    • 2.39.3-9ubuntu6.3
    • 2.39.3-9ubuntu6.4
    • 2.39.3-9ubuntu6.5
    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.39.3-9ubuntu6.6

    Actualiza a 2.39.3-9ubuntu6.6

  • util-linux Ubuntu:25.10

    Versiones
    • 2.40.2-14ubuntu1
    • 2.41-4ubuntu2
    • 2.41-4ubuntu3
    • 2.41-4ubuntu4
    • 2.41-4ubuntu4.1
    • 2.41-4ubuntu4.2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • util-linux Ubuntu:26.10

    Versiones
    • 2.41.3-3ubuntu2
    • 2.42.2-1ubuntu2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • util-linux Ubuntu:26.04:LTS

    Versiones
    • 2.41-4ubuntu4
    • 2.41.2-4ubuntu1
    • 2.41.2-4ubuntu2
    • 2.41.2-4ubuntu3
    • 2.41.3-3ubuntu1
    • 2.41.3-3ubuntu2
    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.41.3-3ubuntu2.2

    Actualiza a 2.41.3-3ubuntu2.2

Fuentes originales

Comprueba tu servidor →