CVE-2026-53614
CVE-2026-53614 · util-linux LIBMOUNT_FORCE_MOUNT2 allows nosuid and noexec bypass
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
util-linux is a random collection of Linux utilities. In util-linux 2.39.1 through 2.41.4 and 2.42 through 2.42.1, the SUID `mount` utility reads the attacker-controlled `LIBMOUNT_FORCE_MOUNT2` environment variable with `getenv()`, allowing a local low-privileged user to force the non-atomic legacy bind-mount path. With an `/etc/fstab` bind mount authorized by `user` or `users` and protected by `nosuid`, `noexec`, or `nodev`, an attacker can race the window between the initial bind mount and the remount that applies those security flags and execute a SUID program from the temporarily unprotected mount, potentially gaining root privileges. This issue is fixed in 2.41.5 and 2.42.2.
CVSS 7.0 · Hoch · EPSS 0,1% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system
Betroffene Produkte und Versionen
util-linux
- Softwareversionen
- >= 2.39.1, < 2.41.5: Betroffen
- >= 2.42, < 2.42.2: Betroffen
Keine Korrektur veröffentlicht
util-linux Debian:13
- Softwareversionen
- 2.41-5
- 2.41.1-1
- 2.41.1-2
- 2.41.1-3
- 2.41.1-4
- 2.41.2-1
- 2.41.2-2
- 2.41.2-3
- 2.41.2-4
- 2.41.3-1
- 2.41.3-2
- 2.41.3-3
- 2.41.3-4
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.41.5-0+deb13u1
Auf 2.41.5-0+deb13u1 aktualisieren
util-linux Debian:14
- Softwareversionen
- 2.41-5
- 2.41.1-1
- 2.41.1-2
- 2.41.1-3
- 2.41.1-4
- 2.41.2-1
- 2.41.2-2
- 2.41.2-3
- 2.41.2-4
- 2.41.3-1
- 2.41.3-2
- 2.41.3-3
- 2.41.3-4
- 2.42-1
- 2.42-2
- 2.42-3
- 2.42-4
- 2.42-5
- 2.42-6
- 2.42.1-1
- 2.42.1-2
- 2.42.1-3
- 2.42.1-4
- 2.42.1-5
- 2.42.1-6
- 2.42~rc1-1
- 2.42~rc1-2
- 2.42~rc1-3
- 2.42~rc2-1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.42.2-1
Auf 2.42.2-1 aktualisieren
util-linux Ubuntu:24.04:LTS
- Softwareversionen
- 2.39.1-4ubuntu2
- 2.39.2-6ubuntu1
- 2.39.3-6ubuntu2
- 2.39.3-9ubuntu2
- 2.39.3-9ubuntu4
- 2.39.3-9ubuntu6
- 2.39.3-9ubuntu6.1
- 2.39.3-9ubuntu6.2
- 2.39.3-9ubuntu6.3
- 2.39.3-9ubuntu6.4
- 2.39.3-9ubuntu6.5
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.39.3-9ubuntu6.6
Auf 2.39.3-9ubuntu6.6 aktualisieren
util-linux Ubuntu:25.10
- Softwareversionen
- 2.40.2-14ubuntu1
- 2.41-4ubuntu2
- 2.41-4ubuntu3
- 2.41-4ubuntu4
- 2.41-4ubuntu4.1
- 2.41-4ubuntu4.2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
util-linux Ubuntu:26.10
- Softwareversionen
- 2.41.3-3ubuntu2
- 2.42.2-1ubuntu2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
util-linux Ubuntu:26.04:LTS
- Softwareversionen
- 2.41-4ubuntu4
- 2.41.2-4ubuntu1
- 2.41.2-4ubuntu2
- 2.41.2-4ubuntu3
- 2.41.3-3ubuntu1
- 2.41.3-3ubuntu2
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.41.3-3ubuntu2.2
Auf 2.41.3-3ubuntu2.2 aktualisieren
Originalquellen
- https://github.com/util-linux/util-linux/security/advisories/GHSA-67r7-8m5w-22wx
- https://github.com/util-linux/util-linux/commit/31e37c1c7dcf25b76ccf41391fe934a75644c661
- https://github.com/util-linux/util-linux/commit/53ff0fcdab12d69c60c971c69a3d0d173fa46ca9
- https://github.com/util-linux/util-linux/commit/9cbfb823500f510b34767edabd3ffd5b436987b4
- https://github.com/util-linux/util-linux/commit/cc81bbcec598cb91f0eb8456282f33eed820ed5f
- https://github.com/util-linux/util-linux/commit/fd6b4d94ff013dc7ed680d4e864610da5b9751f1
- https://github.com/util-linux/util-linux/releases/tag/v2.41.5
- https://github.com/util-linux/util-linux/releases/tag/v2.42.2
- https://nvd.nist.gov/vuln/detail/CVE-2026-53614